Does anyone have a recommendation for a good composite to usb video convertor to use with the HUD in MP? I've got a cheap easycap one but it craps about at a very low frame rate and usually chokes and goes to black screen. I'm guess it can't handle the bandwidth. I'm using a 5.8GHz immersionrc vRx. It just has composite out.

Views: 1458

Reply to This

Replies to This Discussion

Hey Steve,

Here the same.., I'm so frustrated when trying see video under HUD. I did four tests with different easycap, but all are crap.

I'm considering build a GCS with a 10,2" LCD... but I really want carry so many devices to the field, is boring pack/unpack everything.

I'm following...  good luck!

I'm using a 10" screen PLHR96 and it's ok but I prefer to use my 27" imac that I'm already running MP on. I'm using minimOSD so would turn off the HUD overlay. Would be perfect to ditch the 10".

So it's possible the bandwidth problem is something in MP or windows and not the convertor? Anyone successfully using video in HUD?

u probably have a fake. Get the real thing and it works fine.

I'm using the STK1160 Grabber from Syntec, which was about $15 from Tiger Direct. It works great in every video capture application I have installed . . . except for Mission Planner, which only lets it run at 5fps, which is completely unflyable. In Ulead Studio (came with the device) I'm getting 30 fps and it looks great. I kind of need the heads up display though. I'm not sure where the 5fps limitation is coming from. The "grabber" can handle 30 just fine. Mission planner will display my laptop webcam at 30fps. Anyone have any thoughts what I could tinker with?

Tip: Show video in VLC at your GCS computer and restream to MJPG into HUD. Perfect! Here is the command line:

"C:\Program Files (x86)\VideoLAN\VLC\vlc.exe" dshow:// :dshow-vdev="Name-of-video-device-in-vlc" :dshow-adev="Name-of-audio-device-in-vlc"  :dshow-caching=100  --sout=#transcode{vcodec=MJPG,vb=2000,fps=25,scale=1,width=352,height=288,acodec=none}:duplicate{dst=http{mux=mpjpeg,dst=:8080/},dst=display} :sout-all :sout-keep

Then right-click HUD and select "Select MJPG source" and enter   http://localhost:8080

Also see my blogpost at:

http://www.diydrones.com/xn/detail/705844:BlogPost:1234094?xg_sourc...

Thanks, that works nicely. Had to have a friend re-fresh my memory on DOS. We saved it as a .bat file, made a shortcut on the desktop . . . solved.

I've tried this out using my Diamond Multimedia VC500 USB video capture device and have had zero luck.  Tried both using the command line above and using the GUI (Windows 7) to get the video to stream, no dice.  

I can play video perfectly fine in the software that comes with the capture device (5.8GHz) as well as on a normal monitor, but cannot get it onto mission planner.

Any help would be greatly appreciated!  I've attached a pic of the driver and how it's working fine on my desktop using the video software that came with it.

Maybe using a different driver would help?  Are there particular USB capture device drivers that VLC supports? 

Attached some pics of the driver software and how its working with the crap software that came with the device... gotta get it working in VLC or it will never make it to Mission Planner :(.  Please help!

So good news and bad news... 

Good News is, with a couple important settings I got this to show up just fine in VLC.  The devil was in the details, the big setting change was setting caching to 0ms.  It is set at default to 300ms.  I've listed the final settings below.

Bad News is, Mission Planner does NOT like the the MJPEG stream I'm trying to send it using M Osborne's guide.  I'm getting an error in the console log when I try to open the stream, see screenshot below.  Maybe he knows why I get that error?  I followed his guide precisely to setup the re-stream back to Mission Planner, so now I'm a bit stumped.

VLC Settings:

 :dshow-vdev=Conexant Polaris Video Capture :dshow-adev= :dshow-size=720x480 :dshow-aspect-ratio=4\:3 :dshow-chroma= :dshow-fps=0 :dshow-config :dshow-tuner :dshow-tuner-channel=0 :dshow-tuner-frequency=0 :dshow-tuner-country=0 :dshow-tuner-standard=1 :dshow-tuner-input=0 :dshow-video-input=-1 :dshow-video-output=-1 :dshow-audio-input=-1 :dshow-audio-output=-1 :dshow-amtuner-mode=1 :dshow-audio-channels=0 :dshow-audio-samplerate=0 :dshow-audio-bitspersample=0 :live-caching=0

Now Working in VLC:

Error when selecting http:\\127.0.0.1:8080\ as the HUD MJPEG video source:

in your settings you seem to be missing the output type.

in vlc are you picking http, then "Add"

the output stream should have something similar to this

:sout=#transcode{vcodec=MJPG,vb=800,scale=Auto,acodec=none}:http{mux=mpjpeg,dst=:8080/} :sout-keep

Michael, first thanks for all the hard work you've done on this software. It is truly amazing how far this stuff has come and a lot of it is because of the work folks like yourself have done and then graciously offered to share it with us.

In regard to your previous question, yes I absolutely did hit "ADD" after selecting HTTP, and had port 8080 selected as the destination for the stream.  This definitely looks like a problem in VLC, where I click "Stream"  and for whatever reason (has to be a setting) it cannot re-stream the data.  Even though the video can play flawlessly when you open that source with 0ms caching.  I am just having trouble re-streaming it.  You can see it playing perfectly well in VLC in the first screenshot of my last post.

Not sure what setting I have wrong or if there are more specific information I can give you about my setup.  Here it is, for your convenience:

Airborne Tx :

http://www.banggood.com/Boscam-FPV-TS5833-5_8G-2000mW-AV-Transmitte...

Ground Rx: 

http://www.banggood.com/FPV-5_8G-8CH-200mW-AV-Wireless-Receiver-RC8...

Camera (NTSC, 700TVL):

http://www.banggood.com/700TVL-FPV-HD-Ultralight-SONY-Camera-With-2...

Laptop Computer:

Dell, Windows 7 (64bit), running VLC 2.2.1, streaming to Mission Planner 

Capture Device (Diamond VC500):

http://www.diamondmm.com/diamond-vc500-one-touch-video-capture-edit...

Let me know if anyone has had more luck with re-streaming with this device from VLC to the HUD in mission planner.

RSS

DIY Drones Monthly
Newsletter

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2016   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service