I've just finished the construction of my GoDiscover FPV foam wing from HobbyKing, with an ArduPlane controller.  I ran into a serious jitter problem with my analog gimbal servos (your basic Tower Pro 9g micro servo).   They are jittering all over the place (the video is attached).  

I checked around this site and the web, and there was a suggestion that the telemetry unit for the APM 2.6 was causing this problem in a number of builds.   Absolutely yes...  see the videos attached.  When I unplug the telemetry unit, the servos stop jittering.  

As a solution, I may try wrapping the module in grounded aluminium foil (per one suggestion) or maybe just forego stabilization and plug my servos into the FrSky Delta8 receiver directly.  I'd rather have telemetry than stable gimbals.

I'm not sure why there is such a pronounced effect from the telemetry unit, but my conclusion is that you shouldn't be using an analog servo-based gimbal with this setup (at least not plugged into the APM 2.6).  

I'm going to look around for solutions (maybe digital servos don't have the same problem ... I'm going to give them a try today), and maybe grounded foil around the telemetry device will work (then, a little too 'alien mind control' for my thinking).   I'm not sure that stabilization with a Sony HD 700TVL cam (which is what I like to use for FPV) is really a must.

Views: 2117

Attachments:

Reply to This

Replies to This Discussion

Here is a solution that chips away at the problem. 

It seems that the servo jitter is caused by both RF noise and noise transmitted through the power rail.  So I've put a Faraday cage (copper, grounded to the rail) around the telemetry radio, I cut the power lines to the APM 2.6 and ran these back to a separate 5v BEC (see attached pictures).  This cut the jitter 90%.   I can essentially eliminate it by controlling the gimbal servos directly from the Delta8 Rx module.  

There doesn't seem to be a simple solution to this (at least if I keep these servos).  I've tried other more expensive telemetry modules and they put out the same amount of RF noise.  The design itself is just noisy, so you have to cut this noise down with shielding and power isolation. 

Attachments:

There is a simple solution which probably should be done to assure smooth operation of all servos when telemetry modules are connected -- put a 100 microF cap from the signal wire to the ground.  The telemetry unit, even counting sidebands, is transmitting noise in the >100,000,000 Hz range, and the servo control is at worst in the <1000 Hz range.   I have absolutely zero jitter now.  Of course the power for the gimbal servos should come from the second (motor) rail.

Attachments:

Did you put the capacitor between the signal wire and ground of the servo or the telemetry transmitter? Thanks!

The servo and that solved the problem.  I put 100mF caps (I only need to pass 50Hz signals) ... it's a Chinese telemetry module, so their filtering is poor to nonexistant ... my bad, but I solved it.

I'm having the same problem but with elevon servos of a Flite Test Versa. These servos are plugged into the output rail and powered by the ESC's BEC. After placing the 100uF capacitors across the signal and ground, the servos locked into the max position with no response. Should I change cap value? 

I think you could probably go with 1-10uF caps ... I just happened to have the 100uF laying around, and I had a lot of them.  

when calculating the frequency cutoff what resistance value are you using?

I'm saying R=1 ... but in my case, I just experimented

FYI, I had a similar issue but it was mild.  To resolve it, I changed the gain from 20 to 17 and that made the jitter almost non-existent.  I have not flown with it at that setting yet though.  

I was not able to change the setting of the plane's tx while connected to the FC.  Getting a reading from the tx on the plane this way seems very buggy.  I unplugged the tx from the plane and hooked a micro USB to my laptop and the planes now isolated tx and opened mission planner.  I changed the baud to 57600 and selected the com that it populates but do not click connect  (the documentation is wrong here)!  Go to the Initial Setup --> Optional Hardware --> Sik Radio  --> load settings.  The settings will be auto populated.  Update the setting you wish (Tx Power to 17 in my case)  and click Save settings.  Give that a try and see if you have improvement on the servo interference front.  

I think 50mw should be more than enough power from what I hear people say so long as you are line of sight.  If you still get jitters, try dropping the power lower.  You can also try doing this in conjunction with the shielding method above.

Did you experiment with other servo brands ? I've seen users with similar issue but it happened only for precise brands. Maybe some brands are implementing additional filtering caps as you did.

I did not experiment specifically but I can tell you my plane is a mix of Hitec and JR Sport servos.  All were jittering about the same amount except for my elevator servo.  Not sure why that one did not as it is right next tot he rudder servo.  4 servos in the wing and they all pulsed before turning down the power.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service