3.3V chip dead on my 2nd APM

Hi there.
I bought a Hexa B with APM2.5 here in Germany. After installing the firmware I could not connect via MAVLink, it stopped when recieving the parameters. It was possible to connect via terminal but all setup or test functions for the sensors failed. Reading the forums, i figured it was due to the 3.3V chip, so I returned it and got a new one. The new one connected fine, I could set up everything, sensors were fine, and I was starting to finetune everything. Yesterday I tuned the PID setting, holding the copter in my hand in my appartement, powering it up with no problems at all. Today when I went to the field to fly it, the ABC LEDs weren't on and I couldnt arm it. So I went home, tried to connect, but it timed out. After installing the Firmware again, MAVLink stopped when recieving parameters, so i connected via Terminal and had the same Problems as before. Dataflash, Magnetometers and Gyros are not working, so it seems it's the 3.3V chip again. Does anyone know what's causing this? is it an inferior part or could there be something wrong with my power module?
please help me, I just don't want to bother my vendor again and again with this.

Kind Regards

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Were can i buy these chips?
  • This has already been discussed and well documented HERE.


  • U3 is the 3.3V DC reg chip according to the Eagle files...the location is seen below (APM2_5_2_rel3)

    3692911855?profile=originalUse at your own risk... ;)


  • I changed the 3.3V chip and everything works fine now.


  • Hello friends.

    I had usb Connection problems with similar symptoms and the reason was wrong FTDI driver Automatic installed by Windows 7.

    I am not saying this is not Your translator chip, but please check Your Windows FTDI Driver Version also.

    Version 2.08.24 is ok. Higher Version 2.08.28 is not ok.


  • Hi. I have the same problem. APM recently purchased. When connecting it to PC (Win7 x64) gives me a problem than another. Finally when trying to connect to the COM port I can not connect. Disconnect the USB port and try to connect and now my PC does not recognize the device. The APM Version: 2.5.4

    I will try to play the same in another PC.


  • Can anyone identify a pic of the 3.3v to replace? My brand new 2.6 board has the same problem, however I ordered way back in April in time for my build, happening now.. pretty unhappy with the 90 day warranty scheme..

    Is there any chance of DIY'ing this? I'm ok with solder, and it would appear its not loss if I can't return the board! 

  • The same story happened with my APM2.5. Unfortunately, after the 90 days warranty had exceeded... Now I will try to solder a new regulator chip to the board. (Heavy job with that tiny thing...)

  • 3D Robotics

    Sounds like an issue with the translator chip. It's a fine-pitch chip, so there were some production issues a while back with it, but they've been solved for some time. Maybe your vendor has some older inventory? It might make sense to contact 3DR customer support directly for a RMA, which will ensure that you'll get the current version of the board, which is not vulnerable to this issue.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21