I have been running  AC 3.1.5 for some time with no problems. Today I updated to the new AC 3.2, which resulted in accelerometers not calibrating. At one point today  I received an error msg: "Failed to Level: AC 22.0.37 + is required". However, I haven't received any other messages since that one time.

For now, I went back and installed AC 3.1 and Accel Calibration once again works. I see in the AC 3.2 release notes that "AC3.2 also uses the backup compass and accels" but i'm not sure what that means or even how or if it affects my situation.

I would love to upgrade to AC 3.2 - need Help! Larry

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • did you ever get anywhere with this?  I'm 48 hours into this and can't get accels to work correctly on my new pixhawk...  Same issue as you apparently.

  • Thanks everyone for your suggestions.  I tried them all but still no Joy!

    I loaded an older version of the AC ..did a reset and an erase. went back and loaded AC 3.2 ( rebooted) then tried to calibrate accelerometers, again no joy.  Repeated several variations of this scenario, but again no luck.  Compass calibration is good. In frustration, I went back to AC 3.1 and easily calibrated accelerometers.

    What's in AC3.2 thats stopping me from doing this calibration?

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25