Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


      • Hi Miguel, I'm having issues as well updating (though my charset is working fine, just want to make sure I have the latest):

        When powering via USB or USB & 12v I get the following error from Config Tool 2.4:

        Error entering CharSet upload mode - invalid data

        I'm trying to upload MinimOSD_2.4.0.0.mcm.

        Update: if I try the trick of pressing the reset button just after starting the update I get a font error message.  I also checked and my pads are not soldered anyways.

        • Hi Tim,

          If the pads aren't soldered then you really have to have USB & 12v.

          Could you please make a test?

          1. Upload an earlier fw version (like for example r726)

          2. Try to upload the font (2.4) using the latest CT Tool r730

          We made some changes in charset upload so I guess what the problem is.

          I'll be waiting for your reply to make a change/fix in CT Tool so let me know if you resolve the issue this way.


          • Miguel,

            Can you help me with a common issue many folks and I are having? Seems no one can come up with a technical explanation, much less a solution, to why this is happening to so many minim OSD boards. I have been battling this for 2 weeks now!

            The problem is: "Failed to talk to bootloader" I sure you heard about this many times.

            There are many alleged solutions floating out there, from "here is how re-install it" to  "check your fuses/bit locks" (and many others) but none of them actually work.....or make sense.

            Here are the facts.

            1 board from goodluckbuy and 2 from hobbyking. These are obviously clone boards.

            I have all the programming tools, Atmel programmer, AVR Studio, a good FTDI board, latest Arduino software etc, and can erase the Mega328p chip and flash a new bootloader all day long with no problems.

            Then connect to the CT and upload the latest (I tried so many different ones its sick lol) firmware.

            The firmware updates successfully but right after that when the "Done" screen comes up and you click it "Failed to talk to bootloader" shows up.

            I can duplicate this problem all day long within several minim boards and nothing I do changes this behavior. I tried many different variables and combinations.

            So needless to say, I can't update my charset for right after I install the FW I loose my bootloader.

            It works, but the screen overlay is pretty messed up. (as expected without the correct charset update)

            Is this strictly a hardware issue and these clone boards are really that bad of a "clone"?

            Or there some issue with the programming everyone including myself are missing?

            (The objective to get these to work is that there is an obvious big difference between obtaining a minimOSD board for $10 to $15 versus buying one directly from 3DR for $50 bucks!!!!)

            I heard some thing about the memory size of some of this clones being an issue because they can not hold both the firmware and the bootloader but the main chips on the boards are the same; Mega328p for the processing and Max7456 for the video so I imagine this is not true! (even though the 7456 has nothing to do with storing the FW and BL)

            .....or is it true?

            I appreciate your help!

            • Hi Gregory,

              Which is the tool you're using for the charset upload?

              I would use the FTDI cable (just be sure you have both sides of the minimOSD powered either by soldered pads or by the vídeo power on).

              If you have a "Failed to talk to bootloader" issue I would follow this steps:

              1 - Upload the arduino bootloader to the minimOSD with the Atmel programmer.

              2 - Upload the minimosd extra fw with the FTDI cable.

              3 - Upload the charset with the FTDI cable.

              If step 2 fails try to press reset button on minimosd right after you select the fw file in ct tool (your FTDI cable may be failing to send the reset signal to the minimosd).


              • Thank you Miquel,

                It was a reset issue. My FTDI does not have the needed DTR pin for an automatic reset.

                Doing it manually works!!!!

                My minimOSD can communicate now very well via the CT but the charsets do not update.

                Everything else works and I can change the display configuration and save it, and change to any FW at will.

                Except....I can not update the charset no matter what I do.

                Among many others, I tried the suggested combination I read a few pages back;  FW r726 with CTr730 and

                All I get is  "Error entering font mode - No Data" or "Error entering Charset upload mode- invalid data"

                • I got my charset to update. Its all about a good FTDI board with a working DTR pin to send that reset signal to the MinimOSD!!!!!

            • I had several different issues with my jD-MiniOSD v1.2 board, and thought it was a bootloader issue. Bought a tiny programmer and flashed the bootloader and still had issues. Finally powered both sides of the board separately and everything works great now.

              Now when flashing new firmware, without removing the board from the plane or unplugging anything I leave the video battery plugged into the Vtx (powering the 12V side of the board) and plug in my 5V FTDI cable into the header (powering the 5V side) and it works every time.

          • And yes you are good :-)  That did it.

            Just for kicks I tried using CT Tool r730 to update the charset but it also failed.  Then as you instructed I loaded r726, uploaded the charset and then uploaded r785 again.   No errors at all.

            I did notice that 730 has an option about "last uploaded charset" but it stayed blank.  Not sure if that was implemented yet.

            Cheers and thanks!


            • Hi Tim,

              Great to know it worked.

              "last uploaded charset" works like this: When you upload a charset it saves in minimOSD the uploaded charset version. This way you may see which was the "latest" charset you've uploaded.

              However if you upload a new fw this info is lost.

              This featutre is a "work in progress" :)


  • Hello all,

    I have all laying flat now except for the rotation of panels using a free RC channel. I have done radio cal in MP and tried the rotation and 3 way switch approach to no avail. I get panel 1 or no panel with 3 way and no change at all with the rotation. Am I missing something simple?

    Thanks for any help,


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21