Since it has snowed 37 out of the last 48 days here, I am thinking of putting my APM in a RC sled that I made.  I think the biggest issue would be getting it to ignore altitude.  The only controls would be throttle and rudder.  Does anyone have any experience/advice? (besides stay indoors and wait for summer)  Thanks.

Views: 553

Reply to This

Replies to This Discussion

go back in the program library and  find ArduPilot1.0.zip i believe it will suffice for your application

 

http://code.google.com/p/ardupilot/downloads/list

I have the ardupilot mega, I dont think it can run ardupilot code, but I could be wrong.
Ah there is the rub  well load the latest version for the mega  and it should only control the servos connected ,the program will run at full capacity but with only the rudder and throttle connected  only they will operate  and i dont think you have to worry about what is not connected  ,I think !!
You may have to tweak the APM code a bit depending on what you want the throttle to do. If you just want it to run full throttle then the stock code should be OK. Set the configuration for airspeed sensor enabled and set all your waypoint altitudes 100 feet or so above your actual altitude. The throttle should go to full trying to get you up to the waypoint altitude....
Thanks Johann,  Thanks EvilMacaw.  Thanks Doug, I will try what you said and see how it goes, later on I may try to tweak the autopilot to control "speed" instead of "throttle" due to the variation in snow resistance and hills,etc. 

  Ok, so how'd it go??   That has got to be the coolest sled I have ever seen, and might even work ok on water.  I have a fanboat and ROV candidate, and am dying to know more about ground operations.

 

Thanks,

Tim

Well, I am hoping to test it with autopilot this week.  I have had some delays, GPS issues, weather, robotics team, etc.  I have tried it manually on water, snow, ice, grass, tile, carpet, asphalt, cement, and short jaunts in the air, and it seems to work pretty well.  I will post what I learn in a few days, and I hope you do the same.  And thanks for the compliment Tim.

 

Here is a short low-lights video a "friend" put together, this is before the APM, I will be much more careful with that installed.  It needed a fair amount of work afterward.   http://www.youtube.com/watch?v=Wk1Zw8EHycI

I tested the "ardu-sled" today, here is my report.  First off Airtronics receivers use channel 1 for elevator and 2 for ailerons, which is odd. So I had to cross over the wires for channels 1 and 2 between the APM and the receiver.  I have the sled rudder servo connected to APM output channel 1, and the ESC connected to APM output channel 3. 

 

During my pre-cruise static testing the rudders responded to roll instead of yaw like I was hoping.  But I went ahead with some cruise testing anyway.  My waypoints are all set for 100' AGL.  Surprisingly it seemed to navigate around 2 of the waypoints but then take off for parts unknown.  It did this a couple of times but I always had to switch back to manual to avoid running into something. 

 

After a while I went back to the car to get a fresh battery, I left the sled on the near side of the large field and walked a couple hundred feet up a mild hill and behind some trees to the car.  I brought the transmitter with me.  When I came back the sled was gone, then I saw it parked on the far side of the field. This was a really weird feeling, the only thing I can think of that makes any sense is that maybe the APM lost the transmitter signal for a bit and tried to go home.

 

 

I love it, why didnt you show this to us earlier in the season... now i have no snow but its still too cra##y to fly :)

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service