No matter what I do, I cannot get aileron and elevator swapped so they are correct. I am running a Hitec Aurora 9 receiver. I have tried my transmitter in Acro, Heli Swash 0, swapping channels, swapping joystick control modes, swapping cables will fix it, but the copter doesn't fly right because the arducopter controller is confused I assume.  I'm sick of going through props.


Running APM 1.0.52 with 2.0.38 beta code, quad set to x, radio calibrated, one mode switch in stabilize, simple and alt hold. I am trying to take off in stabilize.


I have tried using Ardupirates software and Aeroquad with no luck. I purchased my Arducopter from udrones.


Does anyone have any ideas?


Totally willing to post anything needed to get this thing off the ground so I can start tuning it!




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Moderator

    I didn't realise copters were fitted with ailerons, rudder or elevator :-P

  • Developer

    Do the radio test in the CLI. Move sticks to the lower right (pitch back, roll right) You should see approx 4500 for both values.

    Roll right should happen on Ch 1.

    Then test your motors are hooked up in the correct order based on the wiki. 


  • 3D Robotics

    Your subject line says ailerons and rudder are swapped, but the post says ailerons and elevator. Which is it?

This reply was deleted.