Almost a fly-away video. A few questons.

I had my taranis to set the flight mode channel to RTL as it's failsafe. I did not set the APM failsafe, I should have tested this, but it does not work and I'm not sure I understand why.

Testing on the bench, If I center all sticks and flip my RTL switch, CH5 goes to 1903 and it the flight mode changes to RTL. However if i turn the radio off I get the exact same change, but the flight mode does not change!! Why not? During the flight, the flight log even shows that the mode changes to RTL (the first 2 times, the 2 other were manual i think), but it definitely didn't behave that way. 

I've since turned on the APM throttle channel failsafe and it tests fine. 

About 30 seconds in I got a RSSI critical warning and it started to fall. It recovered but i definitely didn't have good control for about 15 seconds before it started to fly away.

My other question is what made it fly away? from about 0:55 to 1:30 it shows it was in stabilize but I had no control and I was watching it was fly away. I eventually powered cycled the Taranis and flip the RTL switch. This worked but I wasn't sure at the time, as it was just slowly desending. I got impatient, switch backed to STAB, and was suprised i had control again! I brought it back as fast as i could. I was panicking and landed it hard enough to break a landing leg and prop ( i was just glad it was dry)

I think my antenna position was bad, so i'm going to getting one of those printed V stands. I had it in a V but on the leg, maybe too close to the battery. 

Other than testing the fail safe and a walking range radio test, is there anything I could do before my next flight? I still don't feel like i really understand everything that happened. 

Thanks, 

https://www.youtube.com/watch?v=_kgMMOYS3js

2016-03-26 09-55-31.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 1

    Log Vibes.doc

    https://storage.ning.com/topology/rest/1.0/file/get/3702220000?profile=original
    • Thanks, I haven't checked these in a while and they need some attention. 

  • Looking at your log file other than that i see you switched back and foward between RTL and stabilize your quad seems to be set up well your vibration levels are to high if you sort them out your quad will fly well 

    • The first 2 switches to RTL were the radio failsafe switching. The 2nd to were me trying to get the quad to respond. 

      I initially test the vibration levels and they were acceptable, not great. I haven't thought to go back and look at those. I have some carbon fiber props I'm going to balance and replace the cheap plastic ones I'm using now. 

    • FAILSAFE SETTINGS:
      Main Battery = Not Activated
      Ground Control = Activated, with always RTL
      Receiver = Not Activated
      GEO Fence = Not Activated

      You can see by the logfiles the only failsafe you have set is from your GC and not from your radio

      • I didn't think the logs would show what the Taranis failsafe was. It definitely show the flight mode changing, and I didn't manually change it the first 2 times. 

  • Ok, where living on the wild side.  Well since your not using the flight controller failsafe then you loose all the fancy features of the flight controller.

    You were luck here.  The receiver lost contact and did signal RTL but the throttle value went to 930 which would have signaled a failsafe except it was disabled.  This is where it get interesting in that the flight controller continue on in the current mode and throttle.  As the copter is flying out of sight the receiver kicks back in causing the throttle to go back up and the flight controller switches to RTL.

    I think you may have hit a catch 22 in that if the values fall outside the range it ignores the receiver and continues on like if you had a long mission and you want it to continue even if your out of range.

    I think it will work normal if you get the throttle minimum back in range 983 - 2006.

    Also if you have a bad GPS at the time the receiver fails it could ignore your RTL command and continue on in whatever mode it was in and not switch to land.

    • What is odd is that it doesn't work regardless of whether the throttle goes to 930 or stays center stick. If you don't have the APM failsafe set the flight mode will not change even though it appears to me that the input signals (all 8 channels) do the exact same thing as flipping the RTL switch. There must be something else in the SBUS signal that it is picking up that makes it behave differently when the reciever's failsafe kicks in. 

      • Because the Pixhawk uses "last past the line" flight mode changes, it's not a good idea to set the RX failsafe and not use the onboard failsafe.  Basically the Pixhawk takes whatever flight mode it sees last, and sticks with it.  This is why you can switch to RTL from Stab, Auto, Loiter, etc, because the RTL signal comes after those other signals and changes the mode.  If you flip your RTL switch, and then change to another flight mode, the other flight mode will be selected and RTL deselected, even if the switch is still on.  Based on how the RX works, it could be sending both RTL and your Stab switch positions to the Pixhawk at nearly the same time during failsafe, but the Pixhawk sees the Stab command last, thus selecting it.

        For this reason you should set your RX failsafe to a very minimum throttle, in the low 900s lower than your TX can transmit.  Then activate the Pixhawk to failsafe on low throttle.  This way whenever the RX failsafes, the Pixhawk will detect that directly, instead of seeing the RX send a switch command.  

        Ideally you should invest in a UHF long range RC system if you want to push the boundaries and fly into failsafe often.

        • Don,t use the Taranis failsafe its a dangerous option for a multirotor. Set your Taranis TX to no pulse. When the APM senses no pulses from the RX it can select Flight controller failsafe if you have the PWM set correctly in the Mission planner FS line.

          It works great if set correctly.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…