Hi Guys.

 

Just a requiste if someone else has encountered this. last week saterday I flew my APM 2 in a plane all was fine, and today I tried updating firmware and it did not work anymore over USB when clicking on the firmware of my choice, (acro) it would down load from the internet status would change to " reading hex file" that would then go to about 90% and then it will report a " communication error" . I have tested on two different PCs and then I tried over 3 Dr radio ! it works ! but I can not change any settings via Radios just read info.

 

I then found a few blogs about reflashing the chip sets on the APM board , I reflashed both Mega chip and PPM encoder but still no change.

 

Anyone any idea ?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,

    Can you describe what you did when you successfully reflashed? With an ISP programmer? What did you flash, bootloaders?

    Do you know Arduino, do you have it (the special Ardupilot edition) and can you upload a simple example sketch?

    Regards

    Soren

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
xemone liked Max Gilson's profile
Aug 31
More…