Hello community,

we've recently bought the APM 2.5 with the 3DR telemetry kit (433 MHz for Europe) but we now we are facing some problems.

After all settings were done via USB connection we tried out the telemetry. The first tries went well but somehow we can not connect to the APM properly. The green LED is solid but as soon as we hit the connect button it sometimes starts to blink. In some cases it manages to get a slow connection with a signal strength of 5-15% and sometimes it doesn't even connect. After a few tries to connect we sometimes get a stable connection with 100%. As long as we don't change the flight modes the connection stays solid. The BAUD rate is set to 57600 on the APM and the telemetry modules.

We tried to use different antennas which are specially made for 433 MHz, but the problem is still there.

Our second problem is that we are not able to change the NAV ROLL PIDs in some firmware versions (selection fields are grey). We had to downgrade our firmware to get them working. 

Would be great if someone could help us, we are very desperate.

Greets,

Nico and Martin

Views: 630

Reply to This

Replies to This Discussion

It seems like we have solved our first problem by increasing the frequency band from the lowest possible value to the highest possible value.

We also wanted to mention that sometimes the servos stopped in their current position. We could see on the MP that the Ardupliot was initializing again. We solved that problem by using a separate 5V BEC for the output channels without the jumper. So the AP is powerd by the power modul and the servos by the BEC. The Servos aren't freezing anymore and the AP is running smoothly even while changing the modes.

We are still wondering about the NAV ROLL PIDs. In the latest firmware they are not available for us.

greets

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service