APM 2.5 works with usb not lipo.

The APM powers up from the USB port, but it does not seem to power up from the APM 2.5 Power Module I just get single beeping noise and the motors twitch. Also the receiver and GPS are not turning on like they do when I power it from the USB port.  I did not install the separate power source jumper.

At this point I'm at a loss of what to try any help would be greatly appreciated.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi.

    I also have the same problem. The board was working fine and I was working with connecting external LEDs and a beeper to the A5, A6 and A7 ports. Suddenly the board stopped working. I'm quite sure I did not short circuit anything. I was using a power module to power the card and thus; no JP1 jumper. I disconnected the PM and connected the JP1, but still no power.

    I can power the card from the USB port. I can also power it from the input side (connected a battery to the receiver). It then works normally.

    Referring to the diagram http://diydrones.com/forum/topics/apm2-5-5v-vcc-schematic, I have checked the fuse F2 and also the diodes in the enclosed picture. (I'm not sure which is which of the diodes.) They all seem to be ok.

    Any ideas anyone?


    • I have found the reason for the problem. Diode D1 (the diode at the right of the JP1 jumper) was fried.

      I will power the board from the receiver side until I can get it fixed.

      • Can I ask how you found that D1 was fried?

        I am having the problem that I can power the board with the USB... However if I plug my battery in via the Power Module (Jumper Removed), I get weak beeps from the motors and no lights on the APM...

        I am trying to troubleshoot this as best as I can but I am not the best with electronics :-(

        • Hi Cris and sorry for late reply.

          You just use a voltmeter. Connect the minus probe somewhere and measure the voltage on both sides of D1. The voltage should be fairly the same on both sides (a little lower on the output side of the diode). I think the voltage drop over D1 should be around 0,5 to 0.7V)

        • Hello
          are you sure your power module is not fried??
          Today I get in the same situation.
          No power from power module (Jp1 not inserted so APM gets power only from power module)
          APM starts only connecting USB or a bec to the input rail.

          I tried to disassemble the power module and no current comes from 5V pin...
          Only 1,2V from GND+I
          Measuring GND+V or GND+5V gives me 0V on multimeter..
          So may be mine and your power module is Kaputt!
          • Hi.

            Yes, I'm sure. In my case it was D1. Actually, this has happened twice for me on the same APM (don't know why).

            In your case it's obvious that the power module is fried.

          • Finally got around to testing my Power Module... Yep, it was screwed... Showed that it was outputting 15+V rather than the 5.3V it was supposed to be doing... Tested the APM with another Power Module and the board powered up... Whatever voltage protection is built into the board did it's job!!

            Ordered a new Power Module so hopefully that will be the end all to this problem...

            • I think I'm going to buy one without bec or an attopilot and then use a good bec attached to the input rail..

              No more trust in these clones...

    • I seem to have the same problem.  

      I built a Hexacopter last year (APM 2.5) and everything worked great. I had no problem using the USB or power module.

      Last December I built a Quad and calibrated what I could due to the winter.  I didn't have a problem powering the quad using a lipo or USB.  Now, I can't get any power when connected to the lipo.  I'm not sure if the power module died, or what.  Is the APM bad?

      I should add, a few times I would see the APM 2.6 light up for a half a second, then it would cut out.  One time there was a single beep, then it cut out the same.

      Need some advise.   

      • Well, my problem was the Deans Ultra connector from the lipo.  Everything is back to normal.

        - Ready to finish calibrating the copter. :)

This reply was deleted.