APM 2.5: This device cannot start. (Code 10)

Hi,

I received my APM 2.5 a couple days ago and followed the instructions to install mission planner here. Windows didn't locate the drivers automatically so I went to device manger, which shows Arduino Mega 2560 (COM7) with a yellow symbol next to it. I locate the drivers manually (Arduino MEGA 2560), and the following error code pops up: Device status: "This device cannot start. (code10)".

I have found two instances of this happening before (one of them here). Both of the fixes involve replacing a faulty USB cable. I tried using the cable from my phone (which I know works), to no avail. The APM is getting power though, since the LEDs are flashing (red&blue - orange, Green LED near GPS port).

I'm running windows 7 64 bit on my laptop.

Any ideas?

Martin

************************************FIXED******************************************

The APM 2.5 can't be started from the USB 3,0 ports on my laptop, but works fine from the 2.0 port.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi, I used to have an AOM2 that did the same. Suspected hardware problem and replaced the ATMegaU8. That solved it.

    You should of course not have to do that with a brand new one! Sounds like a warranty case to me (if you can't get it to work on a different computer either).

    Your driver installation sounds correct. I have the driver and APM2s working OK on Win7 64 bit here.

    Regards

    Soren

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…