Hi everyone.

I use the APM 2.5 for my projects. At the beginning I was using the arduplane and I loaded the firmware via usb. Everything was good and I was controlling my Bixler type plane. But after that, someting happened and I guess the port`s zener diode or something burnst out. So I havent use usb port anymore and now I am just using telemetry to communicate with APM.

Now I bought a hexa-copter and I have to renew the firmware on APM as Arducopter V3.0.1. But as I said above I cant connect to apm via usb and so I cant re-configure or reload any copter types. The telemetry features is very limited as you know. The system does not allow me any change via telemetry. So I have to solve the usb problem. Could you share your suggestions with me ? 

Thank you

Views: 1798

Reply to This

Replies to This Discussion

I'd love to know this too - My USB actually works to telemetry, but the APM 2.5 crashes when I try to do a firmware update. Everything works fine apart from that, so would like to upgrade to 3.0.1 via an alternative port. I think there is a serial port possibility, but I haven't looking into it yet.

Euan, I once solved a crashing problem during update by using a different computer. I had reloaded some driver that screwed things up.

Mustafa: if its a power problem you could power the APM from an ESC and then connect via USB. Or try jumpering the input and output rails together while connecting, that shouldn't hurt anything
If its not a burnt out diode your cause may be futile. I have had a LOT of reliability issues with both my APM 2.0's regarding the USB connector. Re soldering it on fixed some of them. But its still fritzy.

Just my .02, good luck guys

Hello Mustafa,

Does your USB actually power the APM successfully?

If USB power is successful, is it only a communication issue?

These are two very different problems. If the APM zener were shorted, the APM would not work at all.

The USB connector has a fuse on the APM side. That fuse can open and prevent USB power/connection.


Mr. Starwalt,

When I plug in the USB cable to port, APM power is on , RX/TX lights is working and A-B-C lights also working. However computer cant detect the APM in anyway. I tried it with a couple of desktop and laptop. But again they couldnt define the device. 

So, if something happened which I cant repair, can I use the FTDI cable thhroug UART0 to communicate with APM ? Is it capable to change the firmware and use the CLI terminal like the USB port connection?


Thank you very much for your response Ted. I am checking some of your comments related this problem on your page. I hope FTDI connection will solve this problem. 

The good news is your fuse is OK. That was important.

The bad news is it sounds like your firmware in the chip that handles USB communication may be corrupted.

Here is the schematic for the section of APM 2.5 that handles the USB...

You may, or may not, have a connector on the U8 port. You will need programming for Atmel utilities on your PC. There was a thread in the last 4 months discussing one member who successfully restored the programming. The pin header pointed to by the blue arrow is U8. It may not be clearly indicated on a case but is indicated on the pcb.

I do not think you can communicate with the big chip through UART0. Those ports are for the peripherals.


Thank you very much Mr. Starwalt. But I guess I cant do that anything myself. So I should buy a new autopilot again. Maybe I continue to use the old one for again my arduplane.

Therefore, if you have any suggestion to solve the problem else to use the U8 port, please write me. I will be so glad to you.


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service