APM 2 GPS not getting a lock?

I have been sitting here trying to get a lock with my GPS while outside for about 10 mins.  No luck.  I generally get a lock between 30-60s when outside.  My GPS has worked fine previously.

Other than the CLI test (which only works if I have lock anyway), is there a way to check GPS function?

If my GPS unit turns out to be no longer functioning, what options do I have with the APM2?  Since my GPS is soldered directly to the board, is it possible to get another and use an extension?  I don't trust my soldering abilities enough to remove and replace the current unit

Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The main issue that I found with the onboard GPS is that it is sensitive to anything that can shield the signal, which is above the GPS module (even the odd RC cabling) and secondly the proximity of the reciever, which in my case Optima 7, due to the transmission of data back to the controller this was also impacting the GPS lock and consistency. Basic sugestions would be to remove anything above the GPS module (including any carbon fibre) and make sure that your reciever unit (if it's not purely passive reciever) is not too close or below the horizon of the GPS board.

    Since moving things around and making sure my GPS has a clear sky I always get a lock in under a minute and never loose a GPS lock during flight. The one other element is that a loss of GPS lock during auto makes the waypoint navigation very messy (plane goes into circle mode and then back into auto after a half loop)

  • Just to report back on this issue for me.

    I have replaced my MediaTek GPS modules on the APM2 with the uBlox GS407 GPS and the DIY drones uBlox adapter which lock every time within 2 - 5 seconds regardless of how I power up the APM2 (ESC/BEC, USB, NiMh, input/output rails etc). I have reserved the MediaTek GPS unit for use on the UDB4 which work reliably. I am more convinced that its a timing issue on the APM2 firmware or a software bug for the M-Tek GPS or failing that the M-Tek GPS may be very sensitive to supply power thresholds. I still need to go in and measure the supply rails with a scope to test the latter hypothesis.

    Happy hunting, I see there are many people out there with this problem and I am looking forward to finding (or hearing) a definitive problem an solution.

    Regards

    Grant

     

  • Not sure if you solved this issue for yourself, or the solution has been posted elsewhere, but after encountering this same problem, the fix is easy.

    My problems were: When connected via USB, got good strong lock quickly (<2 mins cold) but when powered on-board via lipo, I got 3-4 sats and 9999hdp. I had the jumper removed as I was powering board from both ends, UBEC on the front end and ESC BEC on the back end.

    Solution: Put jumper back on

    Result: Good strong lock under all conditions, flight ready and via USB

    Hope this helps others.

  • T3

    Problem persists, i get satcount = 0, hdop=9999 and gps=1 from telemetry

    Can we have an official answer about using an external gps? i don't mind if my onboard module  doesent work, if i can do my job with my old APM1 module. 

     

    Is there an other process, beside :

    -waiting for lock for an hour or so, 

    - reset board (warm start)

    - test CLI readings

    -test telemetry readings

    -check for unsolder traces

    - fresh batteries

    -clear sky 

    To check the health of the onboard module??

     

    The only think i've read to forum is cutting the TX trace, but not from an dev member or 3dr member. And without a photo.

    I placed an issue 624 to inform dev team 

    regards

    James

     

  • T3

    I have exactly the same problem, how did it turn out for you?? 

  • It can take 12+ minutes to download the almanac data from satellites into the GPS the first time out of the box.  Give it more time.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…