[Resolved] APM 2 not detected by windows ?

Hi everybody,

I've ordered an APM2 at the begining of dexember an tody is D day ! I've just received my board but it's starting by a big deception (I hope i'm wrong).

I've just connected the board to my pc USB an NOTHING happened ...

Windows, doesn't detect any device ! I tried to change USB port but nothing.

Do I need to power the board with anything else that USB port ? Does it need me power to be detected ?

The board are supposed to be tested so I can imagine that i's working ...

Please help.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Mike, thanks for helping me.

    There is no light on the board. I can't install driver for the moment because the board is not visible in the Device manager.

    I already tried another USB port but not the cable. I don't have another one.

  • Moderator

    Did you load the FTDI drivers?

    Are there any lights on the APM2 when you plug in the USB?

    If not, do you have another USB port or computer you can try?

    http://code.google.com/p/ardupilot-mega/wiki/APM2Code

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…