APM board not arming

Hi everyone,

my brand new APM2 doesn't seem to arm in any way.

I followed the wiki (uploaded the firmware, calibrated the radio etc) yet I cannot get the "A" LED solid and the motor or servos which are plugged in the output rail do not move.

I have kept the rudder stick on the right for many seconds, tried the same with the other sticks but no way, board is not arming. 

I don't think that the output rail is faulty because I have the impression that the PWM signal is sent, servo moves the first time is plugged in and the ESC sound is like the one you get when the receiver is correctly plugged and throttle stick is down.

I have problems with SD card (see here) and I'm powering of the board from input rail due to JP1 not being available in my board! (see here), I don't know if my problem can be related...


Thank you very much for your help,

Michele

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Eureka! After 58 pages of forum readings I solved the issue (at least I think I did...) by ticking "simple mode" in Flight mode configuration.

    CH5 in my trasmitter is currently not outputting anything, so the problem is probably related to that!

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…