We've got two new APM 2.5s from diydrones, and are just getting started with Arducopter (but aren't new to Arduino or embedded systems).

After downloading 2.8.1 hexacopter to them with Mission Planner, we were able to communicate with them through CLI, and connect to them with MP, but not do much else (like radio calibration). Apparently because the APMs kept resetting themselves every 5 seconds (according to message on the console).

Upgraded both to 2.9, and now one appears to be working okay when hooked up via USB. But the other one can only communicate via CLI: trying to connect via MP times out every time.

Is there a debug tool to help isolate what's failing (like, say, a diagnostic sketch for the APM, or an app that would show me what's going on over the Mavlink link? The Windoze version of MP unhelpfully closes the command prompt window on  startup, so I can't see its debugging output like on Linux)?



Views: 1330

Reply to This

Replies to This Discussion

If they're resetting, I'm guessing that they're browning out. Are you using the Power Module to power them?

I can't get my new APM2.5 to connect to MP at all. Older one works fine. How did you get to communicate through CLI ?

Did you load the flight firmware on APM 2.5? Also, have you loaded the drivers for APM 2.5 (they different from the APM 1 drivers)

I'm having the same issue! I'm able to connect via CLI but not trough mavlink I can also upload firmwares. When I try to connect via mavlink it keeps getting stuck on AHRS RP P. I just got the the apm  2.5 yesterday. I think I was given a bad gyro.

This happens when they're connected to the PC via USB and running off USB power, not actually built into the copter.

I'm certain that the one that worked was connected to the receiver, because I was getting ready to calibrate the radio. I think that the second one wasn't, because I was just trying to verify that the firmware download had worked.

I've since read that the APM may reset itself if it doesn't see PPM inputs, and that might be the cause.  I'm going to try installing it in the assembled copter to see if that fixes it.

I'm having a similar issue. It worked fine until I ran ESC calibratoin.

Now I can't connect with mavlink. It times out, but I can use CLI and upload firmware.

John hold the reset button for 30 sec and let me know if you can then re-upload 2.9.  

fixed it for me.

Nothing....same thing

yeah same here, the 30 sec reset does nothing for me. 

I got my new APM 2.25 to work. Even though MP could not "connect" I was able to run tests from terminal so it was communicating. Then I reflashed the quad firmware which went fine, and then restarted MP. Connected fine now. Even flys perfect.

I had the same problem after connecting my APM 2.5 to a lipo, everything was working fine, after having done the esc calibration (that was fine) i disconnected from the lipo, upon reconnecting no abc leds, only power led was on and few blinks of the tx/rx leds, no connection to mavlink nor with usb nor with 3dr radios, strange thing was that the motors were doing some erratic spins with no input from radio tx. I could connect to CLI and upload firmware again (3.1 arducopter quad) but with no results on the mavlink connection. Tried everything like reset button for 30 secs, finally i tried flashing an older firmware (2.9 arducopter quad) and this solved the problem!!! Mavlink reconnected and the board seems to work fine. Then i tried reflashing 3.1 firmware, mavlink seemed to reconnect, at a slower rate than with fw 2.9 and actually i couldn't see any change in the attitude indicator when moving the board. Went back to fw 2.9 and now it works again. Obviously now i will stick with this version, but would be interesting to understand what's wrong with the latest version of the firmware.

Corrado: if you can't connect with the latest firmware, that probably means you have a hardware problem. The 3.x firmware does more rigorous hardware testing and a board that passes 2.x may not pass 3.x. You can do the IMU tests from the CLI to see if your hardware is passing. 

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service