APM Does not load Parameters on connect

Hi Guys

Been going through testing the latest batch of APM 2.6's I received.

I have a problem on one of them, and want to see if I missed anything before requesting RMA.

We have the APM connected to the GPS/Mag ONLY. No other connections, input or output.

I can succesfully load and verify the quad/hex/y6 firmware.

After that I hit CONNECT, and it starts to load the MavLink parameters.

EVERY TIME it gets about 1/3 to 1/2 way, then hangs. not always on the same parameter, it seems random.

I have :

Changed out the GPS and GPS cables

Changed the USB cable

Tried other APMs  - they work 100%

tried connecting the 3DR radios. they connect to each other (green lights), but No comms with Mission planner.

All baud Rates checked and com ports verified, as I said, it works with other APMs.

The only logical conclusion I can come to is that the board is faulty.
Any ideas?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hey Cam, did you return your unit for repair/replacement? How much did they charge you out of curiosity. Also I am interested in what they said in response. thanks in advance! -Duncan

  • I experienced this once with my apm2.5. I pressed the reset button. All went back to normal.
  • Admin

    @Wessie,

    Have you tried connecting with the APM using the CLI in the Terminal Mode?

    Using the CLI you might be able to determine where it is hanging up and what component might be causing the hang-up.

    Regards,

    TCIII Admin

This reply was deleted.

Activity

Joseph Udofia liked Joseph Udofia's profile
yesterday
DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
More…