APM Elevon Mixing Problem

Hi All,

I'm using a DX18 to fly a plane with an APM 2.5 but I can't get the elevons to mix properly.  I set them up on the radio and not matter what I do they don't move in the proper direction in FBWA mode.  I tried switching the channels where the servos plug in but no matter what I do if I get the radio programmed ok FBWA isn't correct and if I get FBWA working I can't get the radio programmed to work in manual.  Did radio calibration several times and tried all of the reverses on the GCS too.  Any suggestions?

Thanks!

Jimmy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Well, I unplugged everything and reassembled it to make sure that I had all the plugs in the right places.  I have proper control with RC and in AUTO but ailerons are still reversed in FBWA.  I have no idea how this could be but no matter what I can't get it to correct the roll problem in FBWA so I'm flying with MANUAL, AUTO, and RTL.  Tuned the plane today and it's doing exactly as programmed so, other than the FBWA problem, all's good.

    Jimmy

  • You need to reverse channels in apm plane using mission planner. Have not tried apm on a plane so cannot point you to the exact setting page but try asking this question on apm forum regarding that.
This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…