APM/Pixhawk: RC Not Calibrated Issue

Today I swapped in a Lemon Rx 8-channel, with PPM output in place of a Spektrum DSMX satellite RX. I tested and calibrated before sticking down the hardware with foam tape. The new receiver bound and connected on the first try. All of the other hardware seemed happy as well. RC calibration worked perfectly. When testing afterward, I can't get past a "RC not calibrated" error. I've recalibrated several times. I put the old Rx back in, recalibrated, same result. I have also tested without any Rx connected and get the same result.

The funny thing is, the ESCs chirp as though I hadn't performed ESC calibration. I've repeated that too. They don't stop chirping when I hold the safety switch.

Hardware is Pixhawk. Software is APM 3.3x.

This copter flew this morning. I'm stumped. Any help would be appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Figured out that part too. I found the RCMAP parameter and remapped the first three channels.

    No more PreArm errors.

  • I figured out what is going on. However, I'm not sure how to correct the issue. So I need to redefine the question.

    It looks like APM is choking on the fact that with the new Rx, my pitch, roll, and throttle channels are mixed up. Since this receiver only offers PPM output, does anyone know how to unscramble the channel order? Do I have to do this in the radio? I have a DX8 and have never tried to do anything clever with channel assignments or mixing.

    Thanks in advance for any advice.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…