APM problem - home lost after time.

I need help.

today I flew my plane with APM (1.02) + MTK16 GPS. On the ground home lock went ok. In the air stabilization mode worked perfect, then switched to RTL, this workedperfect too - from 300m away returned and hanged around me. Then switched to auto and started wollowing the path (3 points at all).

All waypoints passed ok.

After this i played with plane a little bit in the air in stabilization and manual mode. Then i flew cca 300m away and switched to RTL - what a surprise - it started loiter on the last position. I switched back to manual and to RTL more times but everytime with the same result.

Then i landed and switched off the pover. When switched on and got home lock i took of in the air and still got the same results - like it didn't recognize its GPS position, but on the ground i got home lock.

I looked into logs and there i can see - GPS position + alt is from some point locked on the same values.

Any idea?

I can upload also log files from these two flights if somebody interested.


Now i'm going to the field and will try APM 2.012. Perhaps the problem will not appear again with newest APM software.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –