apm wont arm, throttle setting problem

in going through the setup everything goes well

i have an adrucopter set to x quad using adrocopter board. in mission planner i did motor test for proper orientation (no problem)( this quad flew great with kk2,but i want loiter and rtl and all the other cool stuff)

did all calibrations,, but when i arm it in MP the motors all come on.... and i cant arm it with remote,, just get red blinking light,,, i am waiting for flash tool for

Hobby King 30A ESC 3A UBEC

to flash simon k on them,, are the motors supposed to start when i arm in MP?????

when i hook the esc`s to the radio and reattach the positive cable the motors all work fine with full range of speed and stop...,,, gps has lock, using turnigy 9x apm channel 5 is on ch 6 aux on tx mixed with gear switch and 3 position switch to get 6 flight modes,,, when armed with mission planner motors respond to tilting craft to maintain level,, and respond to throttle but not to stop motors,,is there a setting in mission planner to set the throttle to a different level for arming or something,,,,i did radio cal and did put the throttle trim down to calibrate that did not fix it ,so i redid it with trim centered, i have it powered on the tx side with power from the bec going to batt conn on tx with no jp1 , i recieved a bad power module, no power out at all from it. so this is just for test while i wait for power module, do i need to power out put side as well???? ,,or does it sound like an esc problem since all the motors start when armed in MP... please help i have been up for four days trying to figure this out

when i try to run compassmot in terminal it says throttle not zero and exits,, i have calibrated the radio about 15 times ,,,im stuck

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • i fixed this problem by erasing eprom in terminal then loading 2.9b firmware on apm,,did full setup it worked great.

    then i loaded 3.0.1 firmware and setup,,worked well

This reply was deleted.