Hi all,

I have had my APM1 working perfectly for quite a while but now i screwed up... I accidentally touched the Battery Voltage Monitor pins* the wrong way around to the battery balance lead. It was only for a fraction on a second but I saw a small spark :-(.

Now the APM1 only works when connected via USB. Both APM1 and oilpan function as expected**. But if I connect it normally to battery nothing lights up on the APM1 or the oilpan. At first the APM power LED lit up only but now not even that.

The PDB outputs 5V as it should so the problems is after that.

My hardware is exactly the 3DR ArduCopter Quad-B kit

* I am using the built-in voltage sensor

** Connect to mission planner, all sensors working

Any ideas?? I you give me a solution where I get it flying tomorrow I'll buy you a beer, or seven, when you come to Finland... :-)

Views: 2284

Reply to This

Replies to This Discussion

Hello Jon, I have done this as well with the APM1 and APM1.4.  Do you have a eagle file or a way to follow the traces?  I was able to repair mine by putting it under a scope and resoldering a burnt out trace.  That has been some time though.  Follow the voltage meter pinouts under a scope and see what you can find.  What better way to learn more about your APM.  It can be fixed though.  

Hi Todd, thanks for your reply.

I was afraid it would involve "miniature" stuff. That's when we start pushing the borders of my comfort zone...

Visually I cant see anything fried... Dont have a scope though so I might have missed something.

I did some testing with a continuity meter and found that all is ok with the ground pin but the A0 pin (or the "red lead" on voltage meter) does not connect to any of the female headers on the oilpan.


Tomorrow I'll try to resolder the voltage monitor pins and see if that makes any difference.

Any other suggestions or ideas?

I found that if I powered the APM normally on the rail with loads of pins I would not power the APM itself but the whole rail would be powered so the RC unit and some lights I have connected there would get juice.

Right next to where you normally plug in power from the PDB to the APM there are two holes for Vin so I tried to give it power this way. That lead to APM and oilpan powering up but not the big rail. You guys that know the APM better. Does it sound like a fried lead just between the Vin and mail rail? Visually cant see anything fried.

What I then did was split the power cable from the PDB and attached it both to Vin and the mail rail. Everything seems to work except for that there is no signal out from the mail rail to the ESCs*.

* The four top right pins on the mail rail.

Had my first look at the Eagle files and found that these signals OUT0-3 come from the IC3 (labeled Outputs). Leads highlighted with red+blue. Tested these (OUT0-3) with a continuity meter and NONE of them where connected to the mail rails. Illustrated with red and blue circles where I expected a connection...

Is the APM1 fried? How can I be sure the oilpan is ok?

Jon, Check the schematic sections of the IMU and APM for a fuse.

The APM2.X all-in-one boards have this. I cannot, at this time, unwind the *.rar file with the IMU schematic.

-=Doug

Hi Doug,

What do you suggest I do with the fuse? I would be greatful if you could clarify somewhat. I cant find a fuse from the schematics but on the oilpan there is one marked just next to the USB plug. Visually that fuse seems fine.

Hello Jon,  If I remember correctly I think I had to solder a bridge between a burned out trace on the output ground rails.  Check the ground traces on the outputs and work your way up.  What you said in a previous post "Does it sound like a fried lead just between the Vin and mail rail?" sounds logical.  It took me some time with my APM1.4 to find the fried trace, but I did find it.  Those traces are pretty small, so look very carefully.  Take your time and don't get frustrated.   You are learning a lot about your hardware by doing so.  

If you have a multimeter with resistance scale, you can check the fuse for continuity. The part is so small, a visual inspection (without a microscope) is no good. An alternate method of checking a fuse, also with a multimeter, is using the voltage setting and measuring the voltage on each end. If the fuse is good, the voltage will be the same. If bad, the fuse is open or very resistive.

A broken/lifted trace will, as Todd has pointed out, provide the same symptom as an open fuse. My experience with lifted traces usually were preceded with much smoke!

-=Doug

I got the rar file unwound and whipped up a quick combo schematic. There are two fuses..

 

As your USB connection is working, the Shield fuse must be good. The other fuse, on the APM might be suspect. Usually the power from a drone system wiring is provided to the output headers. This +V goes to a diode then a fuse (as in APM2.x) and finally is called Vcc. Notice that APM1 has a voltage regulator for larger inputs than +5VDC. Not so with APM2.x. Several builders are having trouble providing input voltage to specification for APM2.5 and experiencing assorted boot/function issues.

Good luck!

-=Doug

Hi Doug and Todd,

First of all, thank you so much for taking the time to help! It is very much appriciated! Second, thanks also for the encouraging words. It helps...

Third, we might have cracked the case! See the below pic (they are full resolution so might take a while to load):

Thats the "backside" and  sparkfun.com logo. It connects to ground BUT not to the ground on the "main rail". Thats not right? Right?

The other pics: (same letter means continuity meters shows a connection. ? means it does not connect to c.

How can I fix this? Just connecting the two different grounds did not work. Meaning a cable between c and d. That seemed fine except for the OUT0-3 not working. Sounds wierd... Should I triple and quadruple check this?

P.S:

The fuse labeled "a" seems fine. It gives a connection on both sides...

How are your soldering skills?  It is hard to tell if there is a break in those traces, but you could try removing some of the conformal coating and putting a blob of soldering to it.  As long as you don't bridge any adjacent traces it wouldn't hurt to try.  

Yeah something like that needs to be done. But where? The broken part on the sprakfun "c" is just between two traces. And if i understand correctly neighter of these should be ground.

Related: I am debugging now again with a cable connecting the grounds. Everything seems fine exept for that i cant get a signal out to the ESCs. Also tried connecting an ESC signal directly to one of the OUT0-3 pins but no luck.. The OUT0-3 are however connected to the IC3 as they should when the APM is powered so my first post with a picture is no longer valid.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service