APM2 2560 SPI/ISP can not Flash

 While  updating to AC2.7  the 2560  Bootloader  got corrupted and would not work.

 I have tried to flash  the Arduino Bootloader  over the ICSP  but have too many errors.

 Alot of fustrating time later I have to give up.  I tried  different Programers , usbasp, usptiny, arduino as Isp.  Writing  bootloader gets verification error.

I can change fuse to  No Bootrst and load a blink the Led program over ICSP and it runs ok  but can not load the whole Arducopter Hex  over the ISP without error.

I have come to the conclusion that the SPI connections to the sensors is interfering with the ICSP function  and that  the 2560 can not be  recovered .

 

 

 

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Update :

     My Avr Dragon  programer   arrived from Mlaysia and I have a bootloader programed  and the arducopter  FW loaded now.

     The APM  spi bus translator is not an issue  because the reset line  disables it when the ISP programer is active.

     Usbasp, tiny etc  will not work with Mega2560,  In hundreds of google pages this is not mentioned anywhere  except for one reference to the usbtiny.   The  Amel Dragon or AVRispII   is required  to flash the bootloader on the 2560.

    I also found that  programs in Application  memory can not write to Bootloader  memory  so my attempts to program the bootloader with an application program did not work. 

    I could not get the   mega_2560  bootloader  code in the Arduplane Tools repository to work  and I had problems with the stk500v2  bootloaders in the Arduino  distributions  and eventually found a working bootloader from another site .

    It does not  flash the APM2  Leds  but works 100% using avrdude  to upload  an works with Arduino upload but have to enable verbose to make it work .

     

     

     

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
More…