I recently purchased my first autonomous aircraft from 3DRobotics, so I'm fairly new to all of this.  I got the ArduCopter kit with the APM2.5 and right now I'm stuck at the point where I need to calibrate the RC inputs in the Mission Planner.  I did my best to research this problem but so far nothing has worked.  Thanks in advance for your help!!  Even a link to point me in the right direction would be terrific!

Here's my setup:

The APM2.5 is connected to the computer via USB.  The signal wires from a Spektrum AR7000 receiver are connected to the corresponding inputs of the APM.  I have tried everything below with the GPS (uBlox LEA-6), 3DR radio, and Power Module both connected and disconnected.

The receiver is powered by one of the input channels on the APM (via the supplied 2-wire female-female cable).  I did this based on the first sentence of this link which says

For the APM 2 this setup can be performed without connecting a battery. (Generally the USB port will provide sufficient power for both the APM 2 board and the receiver.)

Here's what I've tried:

I read the troubleshooting guide here, but the first line of step 1 says

The USB cable will NOT power the RC receiver.

So which is right?  I'm assuming this last statement was intended for the APM1 but can anyone verify that?

Step 5 of the troubleshooting guide mentions there have been problems with some Spektrum receivers and describes how to bind with it.  However I had no issue binding and was able to control a servo on the rudder channel.  Taking advice from step 8, I then plugged only the rudder signal into the rudder input on the APM but still no green bar anywhere on the "Radio Calibration" screen (still connected to the Mission Planner).

Then I looked at the PWM rudder signal on my oscilloscope and the width of the pulse widened and narrowed as I moved the rudder stick back and forth, just as expected.  But I also noticed that each pulse had a magnitude of only 4V.  I was expecting to see 5V since that's what the receiver was getting from the APM, but I don't know, maybe this is normal.  Also the period between each pulse was 22ms for a frequency of 45.45Hz - but again I don't know if this is normal or not.  Does anyone know if these values are right or better yet where I can find the expected specs for input PWM signals?

I'm now at the point where I'd like to try to power the receiver independent of the APM.  But after looking at the power schematic of the APM2.5 (here) I'm worried about the voltage mismatch between what's supplied by the USB cable (which is made available on the 5V pin of the PWM inputs) and the the 5V line coming from receiver.  Though, I suppose I don't need to send over the 5V line from the receiver to the APM (since I'm still using USB) but I do need to connect the GNDs so they'll be common...  Does this seem like a good idea or is there something better to try? 

As I said above I'm pretty new to this so I'm wondering if I need to do something like reformat or clear the APM2.5.  Last night I updated the mission planner and downloaded the newest Quadrotor software to the APM2.5 but still no success.  Sorry for the long post!  I just want to be clear to avoid confusion.    

Thanks for your help!!

Views: 3609

Reply to This

Replies to This Discussion

Actually I think the problem is with the Mission Planner software and not the APM2.5.  I say this because I can see the raw data from the remote in the terminal window (using the "test" -> "radio" CLI commands) and the values change with the stick movements on the remote.  But when I switch over to the 'Radio Calibration' window there are no green bars... weird. Is this a known issue with MP?

Thanks for the catch on an outdated (APM 1) mention; I've updated that page. 

Did you click on the Calibrate Radio button? It often won't show the bars until you do that. 

Hi Chris, great to hear from you.  I've been following your recent switch from WIRED to 3DRobotics.  Very cool and very exciting!

I did try the calibrate radio button and moved the sticks to their maximum travel (and fully rotated the dial I was planning to use for mode selection) however the results in the pop-up window said all channel values were the same (I think they were all "3000:0").  But when I do the radio setup in the CLI window the range of each channel shows up within the expected range for a working channel, and the last couple channels that I'm not using have identical values that seem correct for unconnected inputs.  This makes me think that the APM2.5 is working but the MP software isn't updating that data to the GUI on the 'Radio Calibration' page.

It might help to know that the green bars appear for a split second when I first view the 'Radio Calibration' window but then update to all grey bars with no green.  Which seems consistent with the values it returns after a calibration on that page.

I'm running MP on my laptop which is running Windows 7.

By the way I'm using a 9ch programmable 72 MHz JR radio with a Spektrum module in the back that makes it a 2.4GHz transmitter.  Though this probably doesn't matter since a servo works in the receiver.

You are connecting via MAVLink (Connect button) before you try this, yes?

Yes that's correct.  Does it matter if I connect (via MAVlink) on a different screen (like the firmware page) before jumping to the Configuration tab?

Last night I reset the APM2.5 using the 'reset' command in the terminal window.  Then reloaded the quadcopter firmware.  But with the same results.  I also tried the previous quad firmware as-well-as the ArduPilot firmware with no success.

I just tried using Mission Planner on a different computer but I still have the same problem with the Radio Calibration bars all being grey.

Also I noticed that the HUD display on the Flight Data page is no longer working (it worked previously).

Any ideas?  I'm really at a loss here.

I'd contact tech support: help@3drobotics.com. Whatever is going on sounds unique to your setup. 

Will do.  Thanks!

No, it's not.  I have a Spektrum transmitter/receiver and the exact same thing is happening to me.  The receiver is properly hooked up to the APM 2.5, but during the radio calibration step, the bars flash green for a second and then turn grey and show a value of 0.

The exact same thing is happening to me.  Did you hear back at all from the help desk?

@Papa,

I believe that you should issue a reset command to the APM in the terminal window AFTER you have loaded in the new code. The terminal window will then tell you to electrically reset the APM after the CLI reset command has been completed.

Sounds like you might possibly have a PPM encoder problem.

@Wolfgang,

Have you tried using the CLI radio calibration in the Terminal Mode to see if a lower level calibration is possible?

Just a thought.

Regards,

TCIII

Yes I did hear back from the help desk.  Ultimately they gave me an RMA number and instructions to send it back to be fixed.  If you're interested here's how we came to that conclusion.  

In their reply email they first suggested that I reformat the dataflash by going to the terminal tab and typing in "logs" and then "erase".  They said this can take a few minutes but that it only needs to be done once.  However when I entered the command "logs" it froze and I would get no more feedback from the APM2.5.  The weird part was that all the other commands (ie "help", "setup", "test) worked fine.  I explained this new issue and they asked if I ever saw a message like "cannot find dataflash" or "please insert dataflash".  In fact I had seen that message and that indicated to them that there was something wrong with the board and they gave me an RMA number and instructions to send it to them to check it out.  I mailed it back today so that's all the info I have right now.

In their last email they said that this problem seems to suggest that the power regulator on the board might have been damaged which they said can happen if it's supplied more than 5.5V.  However in my case I've only had the board connected to my computer.  And after checking, it turns out my computer is putting out 5.04V on the USB power pin - which is healthy for a USB connection.

Since you're having the same problem I would first try to reformat the dataflash as mentioned above and if that doesn't work then definitely shoot them an email. 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service