APM2, Code 2.6... can't get failsafe to activate

Hi Everyone.

 

  I'm using a Spektrum DX8 with an AR8000 receiver.  It's setup for 6 flight modes and I did a binding to a Failsafe Preset.  If I hookup my hexcopter to Mission Planner and shutoff my radio, I can see in Mission Planner that:

 

1) My throttle goes to 926us

2) My flight mode goes to RTL

 

However, after getting all this working, I took it out to the field, waited for GPS lock, then lifted off about 3 feet and landed.  Then I left the props running at very low speed and carried the hexcopter to a new position about 300 ft away.  At the new position, I verified that I was still armed (by lifting off a couple feet), then landed but left the props running on low (so APM2 would think it was still flying).  I then shut off my radio.  The props immediately quit running.  After a few seconds, I turned my radio back on and was able to take off without re-arming --- so the hexcopter was still armed... but RTL never caused the Hexcopter to Return to Land.

 

I brought it home to look at the logs, but are basically empty, so they were not any help.

 

Reading the forums, I've not run across any steps I've left out, but there must be something I'm doing wrong.

 

Any ideas?

 

Thanks,
Dustin

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • First, test failsafe with the props off, never the way you just tested. The problem is, if the TX is off, you have no control and thus that spinning blades could have become your worst nightmare. Shame on you and consider yourself lucky. You could have easily determined the functionality with no props and a lot less danger.

     

    There is a known "feature" of the PPM encoder that too low of a signal on the throttle while the other channels remain valid or centered results in the PPM continuing to send the last known good throttle signal. Being that you were idling, shut off the TX causing the RX to go failsafe, either the throttle was low and remained low, or the other option was the TX dropped all outputs to zero and the PPM then dropped out so you didn't seem to activate runaway mode, but again, that's why I'm warning you since likely, you are going to be playing with settings and that's a very real possibility. If you hit the magic setting (and trust me, by having it idling and then turn off the TX, that's as close as you ever want to get to the exact situation known to cause a runaway).

    http://code.google.com/p/arducopter/wiki/Failsafe

    http://diydrones.com/profiles/blogs/spektrum-dx8-and-ar8000-failsaf...

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Wednesday
gotham liked gotham's profile
Dec 3, 2020
More…