APM2 - No power from LiPo

HELP!

Following a crash that wrecked my 1st DIY Hash-octocopter,

I have now happily completed my second, SteadiDrone based octo - real nice!

The APM2 board, that lived through the wreck, will now not power from the Lipo.


Power Scheme (4C Lipos)

2X Lipos -> Wiring Harness  (in parallel)

Wiring Harness -> 8X ESCs   !!! Power Up and beep

Wiring Harness -> CC UBEC -> 5v -> VOLTair power distro  !!! power tested & OK

VOLTair PDB -> (+5v / Red) power feed on output 2  **

APM2 Jumper: ON

Rx signals connected, including power from APM2 to Rx

** Note: All wires from ESC to APM2 have their +5v/Red wire CUT

          +5v is bridged to the second connector from the UBEC, all ground common.

           This has been tested and worked on my previous build.

 

When powered from USB only:

1. APM2 powers and boots OK

2. Firmware loads OK, COM connection established, Radio Calibration OK etc.

3. Magnetometer OK, North reading OK

4. GPS OK, correct 3Dfix established (5 sats..)

5. Input and Aux rail shows ~4.75v

6. Output rail @ 0v, but I assume that is normal

8. Output rail Signal shows ~2.5v,

9. Board will not arm

When Powered from LiPo via UBEC (no USB):

1. APM2 appears dead, no lights, nothing

2. All 8 ESC's play their startup note and proceed to beep in unison once a second or so

3. Output rail power reads +5v

4. Input & Aux rails read +0.25v

 

When Powered in parallel (USB + Lipo):

1. There seems to be no communication between Rx/APM2 and Output rail / ESCs,

2. Can't arm board

3. Can't calibrate the ESCs with the throttle procedure.

4. CLI motor test doesn't work

5. Resetting APM2 provokes a beep from the ESCs

6. Reconnecting to PC/USB provokes ESC beep

Any ideas anyone, or is this board toast?

Thanks -

Gil

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Gil, Have you looked over the possibilities shown on THIS schematic?

    When you say 'VOLTair PDB -> (+5v / Red) power feed on output 2  ** ' do you mean you are inputting DC volts to the IO rail?

    -=Doug

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…