APM2 not Ready to Fly on LiPo

Hopefully someone can help me out here.  I have a 3DR quad with APM2 that I've been trying to get to fly.  But the quad wants to flip on take off.

At first I thought it was a bad esc since I thought I could fly without the data card, but it seems like you need the data card from the reading I've been doing.  But before I figured that out, I changed out all escs from the kit 20As to my spares 30As from my hexa.  I also swapped motors with the one that wants to flip the quad, to see if its a motor or something else.  I changed configurations from X to +, but the same result.  I could only ever get it to go ready to fly without the data card while powered by lipo and I think that's the main issue.  Something is not initialized on the card or something is just wrong with the APM2. 

When powered by LiPos the blue & red leds do not flash.  Only the Rx/Tx.  I've waited plenty of time to see if the blue & red, ready to fly flights turn on but nothing.  I can only get the LEDs to flash properly if I take out the data card, but then it wants to flip on take off.  So I think it's a data card/initialization issue.

From other threads, I've tried the following:

Connect via terminal (no mavlink)

Enter CLI

-> test

-> logging

This said it found the data card, and the card was the proper version of card

So I continued, and erased the logs with

-> logs

-> erase

Booting with USB gets the blue and red led to flash, as ready for fly but on lipo power nothing happens.

Any suggestions?

I'm running the latest mission planner 2.6 version available.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So after a fresh erase, and 2.6 upload with a new esc calibration I can get it to take it off and doesn't want to flip.  So the flip issue is taken care of, but that's not what the topic was about. 

    Now, why does it need to be connected to MP in order to get the ready to fly lights?  Booting direct from Lipo does not give me any ability to fly, which means I need to bring my laptop with me if I want to fly.

  • I did have JP1 installed, but I was powering from the outputs.  Took it off, and now powered from the inputs.

    Here's the video of the motors test.  https://www.youtube.com/watch?v=EC0j3OlIONM

    It's all correct based on the wiki.  All motors push air.

    Here's the video of it wanting to flip.  https://www.youtube.com/watch?v=62FSH9nlunc

    I'll re-calibrate the escs again, erase and re-upload 2.6 and see what happens. 

    Are there any tests to check if the APM2 is fully functional?

  • I had the same problem last week on 2.6 on a octaquad config. The flipping at take-off issue arised after I reconfigured my ESC voltage cutoff and range, I thought I had messed my timing or something in the ESC but re-loading the firmware on my APM2 solved the problem. Since then I have been having issues with the APM2 not starting up on LIPO and having to plug the USB cable and connect with MP to get the blue and red LED to flash and be ready to fly.
    The strange thing is that this startup issue only happen when I am at the field, it seems to be fine indoor. I thought it could have been the newly installed sonar but I tried with and without with same results. I haven't flown since these issues and so far it seems to have disappeared on its own from the testing I have done in my backyard.

  • Moderator

    Look at your board. Find JP1. Is there a jumper installed?

    Flip on take off almost always means that either the motors are connected to the APM wrong, or the wrong motors are on the wrong arms, or one or more of the motors are spinning the wrong way, or one or more of the props are not correct for the direction the motor spins. Verify each of these things. See http://code.google.com/p/arducopter/wiki/AC2_Props_2

    If all of those things are correct, then see http://code.google.com/p/arducopter/wiki/AC2_Troubleshooting#ArduCo...

This reply was deleted.