APM2 telemetry using xbee pro S2B

I am having some difficulties setting up telemetry for an UAV and hope to start this post to pool some ideas.
i am using APM2 with the latest firmware ArduPlane V2.50 uploaded to APM2 using mission planner 1.2.4 mav 1.0

on the APM2 side i uses the xtremebee board

modem: XBP24BZ7
function set: ZIGBEE ROUTER AT  
version: 22A7

on the PC side i uses the xtremebee USB adapter

modem: XBP24BZ7
version: 20A7

both xbee are XBee PRO S2B

they uses the same PAN ID  and share the same baud rate 57600

i also tried different baud rate and different digit of PAN ID which do not matter as long as they are the same in both board.  (except 38400 does not communicate)

having matched the SH DH SL and DL i am able to establish a clear communication between the two in X-CTU. it passes the loopback test with 100% and able to return what i type in the terminal tab.

when i try to move on to the mission planner i am unable to get a connection even with the same baud rate and correct COM port number. i get an error saying "no heatbeat packets received" after the 30 second timeout. yet, over on the terminal tab in mission planer i can use "+++" and "atnd" to detect my xbee on the APM2.  and this is done with the APM2 powered with an external battery and xbee on the PC connected via a USB cable.

i am wondering if anyone is able to show me the rope?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • here i am trying to fix this problem and i use " xbee pro s2b " modules and the mission planner gives me the same error ??
    how can i solve this error ? i made the 2 xbees on the same baud " 57600" and the mission planner also when i connect it i use baud " 57600"
    i am connecting one xbee with the telemetry port in the apm 2.5 and the other with the computer which is supposed to connect to the mission planner to read the logs from the apm 2.5 
    so what is the steps to overcome this problem ??
    thanks in advance

  • great news!

    APM2 successfully communicate wirelessly even with 2.4GHz xbee pro 2

    after they were connected in mission planner they didnt seem to transferring anything so I re-upload the firmware to the APM2. the mission planner not only showing "armed" but also showing the movement of the board. apparently the firmware got mess up in the process.

    a word of warning though, when disengage the APM2 from the PC make sure the "disconnect" button is press or you will have to go through the unbricking process of the xbees (X-CTU -> restore -> rewrite)

  • i realized i made a silly mistake where i forgot to undo the loopback wire on the APM2 side. so i am guessing when mission planner tries to connect to APM2 the signal comes right back, hence "no heatbeat packets received".  after taking it off and turning the switch to "master" and trying some different baud rate (end up using 57400) the xbees starts to work. the light of either side stays on whenever they are powered. 

    my new problem, however, is after it is connected to the mission planner, none of the compass status is delivered. it said to be "armed" but when i move the APM2, nothing is changing. everything stays the same as if nothing is connected.

    does this happen to any of you?

    am i missing some setup?

  • sorry  forgot to mention the RSSI led on both side of the xbee is on when i click connect in mission planner

    and the switch on the xtremebee is on slave

This reply was deleted.