This is my first post here and I am new to the Arducopter and APM.  I have not been flying very long, but my experience has been with DJI naza controller and I found that very easy to fly.  I have a DJI F450 quad and a xAircraft (frame) built hex.  

I bought a used arducopter hex and am having problems with getting it running correctly.  After some initial frustration in getting my TX (Spektrum DX8) set up with the APM, I finally reinstalled the firmware and got that taken care of.  It is a factory built hex with 850kv motors, APM 2.5, ublox gps, sonar, telemetry, Spektrum AR8000 RX.  According to the previous owner it flew very well and was used with a Spektrum DX7.  I figured it would be no problem just binding to my DX8 and leaving all the settings in place.  No luck with that.  But could have been my total lack of experience with the arducopter system.  I am using the latest mission planner.  Connection with mission planner is good.  Everything seems to calibrate ok, including esc calibration. 

I created a video of the problem. Here is the link:

If you listen to the video you can hear the throttle problem.  I arm the APM, then give it just enough throttle to spin the motors.  You can hear the "jumps" in the throttle.  I am not touching the throttle on the radio, it just has sudden momentary jumps.  You can also notice a slight increase in throttle at about 23 sec in the video.  At about 30 sec in the video I apply some elevator and aileron just to test that.  There is also an occasion "clicking" noise when the APM is armed, but not sure where it's coming from.  
This same thing was happening during test flights in stabilize mode.  I did not take it out for any further test flights because I am concerned about the problem.  When I was test flying it before, it did the throttle "jumps" while flying and then it would start to lose power and slowly come down, but when I pulled all the back on the throttle, the motors would keep spinning.  It's a bit scary and frustrating and it's driving me .  Any help would be greatly appreciated.

PROBLEM SOLVED (I think): I changed the frame rate on my DX8 from 22ms to 11ms and the throttle spikes went away. Hopefully I can now move on with flying!!!


Views: 652

Reply to This

Replies to This Discussion

Any help with this would be greatly appreciated.  Thanks, Mike

Can't comment on the AR8000RX problem as I don't use that equipment  but the clicking sound is relatively normal.  There are a couple of threads on here about the clicking and generally they all lay the blame on the timing between the APM and the ESCs.

There is a thread about using the AR8000RX here: that may help you out.  The advice seems to be to go through the rearming sequence/esc calibration process again.

Hope it helps!


Mike, thanks for that reply, but I don't think that's really the problem.  I've been through the esc calibration several times, but does not seem to change.  If you watch the video and listen to the motor sound, you can hear small throttle bursts that when the props are mounted make the copter jump.  This happens with the throttle set at a constant and leaving it there.  The whole system is stock build by 3DR.  


Yeah, I thought that you had probably already gone through the calibration process but I hadn't seen anything like the problem you're experiencing so I figured that we might was well start with the basics. :-)

Have you tried rebinding the Tx to the Rx?



Yup, and I just went through and did a rebind and recalibrated the esc's again now just to make sure.  Same exact problem.  Arm, input throttle, let it run at constant throttle and you can hear the short bursts of increased rpm going to the motors.  I contacted 3DR tech support and sent the video for their review, but no response yet.  I had high hopes for using APM, but I had also read a lot of the problem stories with it.  I guess I was hoping I wouldn't become one of the problem stories.  Oh well.  Thanks for your input though, I really appreciate it.

Sorry I couldn't help Mike.

I hope someone drops by with more knowledge than me. ;-)

If you do come up with a solution, please post it up here so we can all learn from this.



Problem solved (I think)!!!  Here's a link that got me going:

Appears to be a problem with the DX8 TX combined with the AR8000 RX and using the gear channel.  By changing the Frame Rate on the DX8 from 22ms to 11ms the throttle spikes stop.  I finally found a bunch of stuff online about these throttle spikes, but the above link was the most helpful.  




Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service