ArduCopter 2.7.1 Released

ArduCopter 2.7.1 will become available on Mission Planner and in the downloads area shortly. This release contains a few important bug fixes as well as the first implementation of the MPU6000 sensor-fusion code. 

Detailed changes are in the commit log. Here's a summary:


- Preliminary support for MPU6000 on board sensor-fusion (DMP)

- AP_Limits: Experimental "bounce" mode, for smaller spaces (LIM_RECMODE)


- Bug fix for yaw error buildup on takeoff

- Fix in Auto mode for failsafe handling

- Fixes to 3-axis camera gimbal code

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Spent some time trying to setup my clone F450 with the APM2.It hovers now. But seems to have this funny wobble issue. I have been dropping the Rate P down to lower the effects of this. Currently at 0.09.

    The wobble seems to cycle every one second. Almost like the quad is shivering every second or other second.  Should I keep lowering the the Rate P?

  • Hello, if I have a wobble in my 3dr frame in stablize mode can this be a direct result to a bent shaft? I have ordered the 3dr motor shafts and was wondering if it will fix the wobbling or is it part of the 2.7 release? 

  • Hi Marco,

    very nice just watched it :-)

    Is it normal now on auto land for the quad to bounce several times before stopping??

  • Developer

    ArduCopter V2.7.2ß - Full Auto mission video:

    Hi all! I was required to publish a video with a complete auto mission, take that! :-)
    Auto takeoff, 9 waypoint, return to home and autolanding, with "yaw hold" enabled (nose of the quad always in the same direction), wind 10 km/h, this GIT.
    Yestarday i repeated the same mission for at least 10 times, without a single problem.

    I move the throttle stick in the middle position during flight to stop the mission quickly in case of problems, not for all (switch in Acro mode with zero throttle is not good, LOL).
    I apologize for the drunken filmer (LOL), unfortunately there were no clouds in the sky so my cam often out of focus sometime, soon I'll do something decent video with more than 30 waypoints in long distance.
    The hops during landing are normal for my quad, it weighs a lot, also the ground is very hard, no rain for more than 80 days here.
    I've all the telemetry logs about this mission.
    My parameters: i reduce a little NAV_P (1.5)
    , NAV_I (0.08), THROTTLE_P AND ALT_HOLD_P, increase LOITER_P and I, all the rest are default.
    The secret to a good stability is to fly with quite large propellers.
    Still a little patience and version 2.7.2 will be available on the planner.

    @Allen: yes, u-Blox gps unit is full compatible with APM1!


  • My apm seems to lock up. I can arm it and spin the motors very carefully, but it freezes suddenly. Looks like it jumps out of armed mode because rearming with the sticks worked.

    I wonder if theres an hardware fault or if the firmware reacts to low throttle in some way and dearms?

  • I decided to give 2.7.1 a try today. After it bricked my telemetry module again I decided just to fly it.  ALT_HOLD was acceptable but in LOITER mode there was that definite "aggressive twitch/wobble" input that some people were describing which wasn’t there in 2.6...

  • Developer

    APM Planner 1.2.7 - Auto WP Grid & Circle generator:

    Hi all... have you seen the new planner implements these new features?
    Are very useful for generating automatic missions for take video and photos during a logical path (like photogrammetry and other).
    Thanks Michael for developed my improvements!




  • My quads loiter perfectly with 2.7.1 without any twitch or wobble. Apart from the lower speed that I have to use for waypoints from 2.7 onwards, I noticed another issue with my last two flights.

    Both were waypoint flights in excess of 4.6 km, but after the last waypoint when it starts decending in LAND mode and I switch to STABILIZE, the throttle doesn't respond properly. The quad keeps descending even with full throttle. Once it seemed to recover somewhat after a while, but today I had to make an emergency landing at the bottom of the hill.

    That reminds me: Is there any way to fly waypoints lower than home altitude? My takeoff point is at the top of a hill.

  • A very pleasant and stable flight shame that the four charged batteries no longer as before. will not know if the bat or more before consuming 2.7 lasted seven minutes each, now only 3, I test the many exhausted.

  • Hey guys, here's my little bit of contribution which I hope will help the developers and users solve some of the issues I've run into.  My hexa had been grounded ever since the 2.7.1 update but I found a solution.

    I am flying an ArduPilot Mega V1.4 with the Rev H v1.0 IMU

    I do not remember which firmware version I was on prior to the update.  The update resulted in 4 props spinning instead of all 6.  I noticed that output channels 7 & 8 were no longer logging any signal.  I was just getting a 0 value on both.  However output channels 5 & 6 were now responding to throttle input...which was weird.  So I connected the two none working motors to channels 5 & 6 but this resulted in problems with the ESCs not recognizing the signal properly and giving me error beeps (despite recalibrating them individually).

    I ended up reloading older firmware versions until it worked.  The newest version which brought everything back to normal was version 2.5.3.  Since some people are having success with the latest version, I'm guessing that changes in firmware versions beyond 2.5.3 must have some incompatibility issues with certain APM hardware configurations.  In any case I hope that this will help track down what changed beyond 2.5.3

This reply was deleted.