Arducopter 2.0.26

Today I thought id try the latest 2.0.26 firmware. also got the latest mission planner.For some reason I'm not getting any flight data when I connect to the mission planner. It connects successfully and I can use the terminal when I go into CLI mode. If I go into fly mode to see flight data, it connects, the rx and tx lights flash. but no flight data, raw sensor values, radio data, nada. Im just connecting via USB, dont have xbee's.Earlier today with the previous 2.0.23 code it was working fine.Am I doing something wrong or missing something?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Ok. With new mission planner 1.0.18 and new firmware 2.0.28, feedback from the APM via USB returned to normal. Everything ok now :) Thank you ...

    P.S. Eager to receive my new motor and make another flight test.

  • 100KM
    I have the same problem, is the cause known already ? Any fix available ?
  • Hi Brett. I hit the reset button on the APM as soon as it starts to try connecting, and it usually connects successfully then, have you tried that?
  • Developer

    I have the same issue. Looking into it.

    Jason

  • Same here. I noticed the following : If I connect using radio telemetry, I get flight data and sensor reading, but via USB it's not working. That happens also with HK ground station and previous version of APM Planner, so I believe it's something in the firmware.
  • Did anyone get the chance to try alt hold?

    I tried for a short while until a ran out of packs and it got dark. When I enabled it would just start climbing. But I didnt have much time to play. Will try again tomorrow.
  • same here.
This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…