Developer

ArduCopter-3.2.1 Beta Testing

ArduCopter 3.2.1-rc2 (release candidate #2) has completed beta testing and has been released as the official version available through the mission planner and other ground stations.

Changes from AC3.2 are listed below and in the ReleaseNotes:
1) Enhancements:
    a) reduced twitch when passing Spline waypoints
    b) Faster disarm after landing in Auto, Land, RTL
    c) Pixhawk LED turns green before arming only after GPS HDOP falls below 2.3 (only in flight modes requiring GPS)
2) Safety Features:
    a) Add desired descent rate check to reduce chance of false-positive on landing check
    b) improved MPU6k health monitoring and re-configuration in case of in-flight failure
    c) Rally point distance check reduced to 300m (reduces chance of RTL to far away forgotten Rally point)
    d) auto-disarm if vehicle is landed for 15seconds even in Auto, Guided, RTL, Circle
    e) fence breach while vehicle is landed causes vehicle to disarm (previously did RTL)
3) Bug Fixes:
    a) Check flight mode even when arming from GCS (previously it was possible to arm in RTL mode if arming was initiated from GCS)
    b) Send vehicle target destination in RTL, Guided (allows GCS to show where vehicle is flying to in these modes)
    c) PosHold wind compensation fix
    d) prevent infinite loop with do-jump commands pointing at each other
    e) pixhawk memory corruption fix when connecting via USB
    f) vehicle stops at fence's alt limit in Loiter, AltHold, PosHold (as it did in AC3.1.5)
    g) protect against multiple arming messages from GCS causing gyro calibratoin failure

Thanks to Raph for the video.  This is actually a video from AC3.2 until we have one specific to AC3.2.1.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Did some 3.2.1 beta test. A little over 1 minute things went south and I had a crash. From what the logs seem to indicate, I had an err in flight mode-8. That seems to indicate a failsafe issue with GCS. While I normally use a GCS, I do not use it to control the Arducopter, simply gives me telemetry. I checked my configuration and GCS failsafe was disabled. The log is included.

    2015-01-29 10-04-00.log

    • Craig.. Just fyi I had two crashed because props broke. I guess no wonder they were cheap ones on eBay like this [ see link ] . I threw about 40 of them in the garbage. The first time I thought it was a fluke. The second time I had just came back from flying way out over the ocean... it was 20 feet up over a tree and almost home when it broke. very lucky!  There was zero warning it just snapped near the inside. Anyway just thought I'd mention it I don't know if that was your issue or not. But if anybody reading this has cheap china nylon props throw them out! 

      http://www.ebay.com/itm/8pcs-10x4-5-1045-Nylon-CW-CCW-Propeller-Pro...

      • I have yet to have my props fail unless I hit something. I keep plenty around should that happen. As it turned out, this was a pilot error pure and simple. I should have had it set for PosHold. I have yet to find a reason to use position.

    • Hi Craig,

      I believe your crash was due to a motor or propeller failure.  Very shortly before the loss of control, the vibrations suddenly increased significantly, then the motor output became noisy (ie: controller either responding to the vibration noise, or struggling to maintain attitude with a failing thruster), and then finally the system is unable to control attitude and it flipped and crashed.

      Earlier in the log, you do have an ERR:FLIGHT_MODE-8, which means that it failed to enter Flight Mode 8.  This is because Flight Mode 8 no longer exists.  This was the *old* "position" flight mode, which was basically like Loiter with manual throttle.  You have your Ch5 mode selection Mode 4 set to 8.  This is no longer valid.  And it does appear you changed your mode switch to Flight Mode 4.  So basically it failed to change into a mode which no longer exists, but this is fine, it just stayed in the old mode.  The crash happened much later and seem unrelated.

      May I ask how or why you have Flight Mode 4 set to 8?  Did you enter that manually?  Or perhaps there's some error in Mission Planner?

      It is unfortunate that the new Position Hold flight mode is so similar in name to the old Position flight mode.

      • I'm glad to see I am not the only one with Position/PositionHold problems.

        I also have seen ERR: Flight MODE 8 errors and this is what I have found out.

        I couldn't get position hold working using mission Planner, instead used APM Planner.

        I am not able to choose pos-hold on three instances of mission planner but find that instead, I have position in the list not Pos-hold. 

        It is invalid though, the copter with 3.2 or 3.2r1 will not switch into the old position hold mode. I have tried mission planner 1.3.16, 1.3.17 and 1.3.19, and none will allow me to select pos-hold, instead, the old "position"  is in the drop down list.  I have posted some information in a thread mentioned in my last post.

        I did find out that if I use APM Planner instead, I have no trouble setting the position hold flight mode and it works.

        Check out the thread mentioned above to see more information..

        Richard Evans

        • Developer

          Richard,

          I guess you've figured it all out but just to be clear, the issue here is caused by using a very old version of he mission planner.  On the flight controller side we don't force the user to use a particular version of the ground station (because there are many ground stations).

          I guess we could add a pre-arm check to AC3.3 that ensures the user doesn't have any unsupported flight modes setup on the FLTMODEX parameters.  That would catch the problem before takeoff at least...

          • Hi Randy.

            No, 
            I haven't got it figured out at all.. Thats why I am asking for help.  I appreciate any suggestions, I would like to be able to use Mission Planner, and not be stuck with only using APM Planner.

             I am using MP 1.3.18 on one of my laptops running windows 8.1, (I have three windows machines (XP, Windows 7 and Windows 8.1) I also have a MAC running APM Planner but as I said it works fine.   I have tried MP 1.3.16 through MP 1.3.19, I haven't tried any Beta versions.

            So, that's what I don't understand when you say this is caused by a very old version of Mission Planner. 

            Here is a capture from the console as I am loading MP 1.3.18  using Windows 8.1   when I a, loading MP 1.3.19  in  Windows XP, I get a different error, so there is an inconsistency that I don't understand, but in each case, the error seems to be when it is loading the modes list.

            windosws8modelisterr.PNG?width=320

            Here is the error I get running MP 1.3.19 in windows XP

            mperror.jpg?width=320

            Don't get me wrong, there are a lot of you that know this stuff much better then me, I have a "lite" knowledge about MP and the Firmware etc.  

            I have three copters that are operational using Pixhawk, and for a while I was changing modes assuming I had switched to Pos-hold and wondering why it was so unstable.  I have to admit, that was pretty dumb, it tool me a while to realize although the Taranis was telling me with voice prompts that I was in position hold, and when I looked at the drop down in MP, it said Position when I flipped my switch.. then I discovered, it wasn't really changing modes..

            My first experiences were with "position", and I thought it was great. I guess at some point I lost it when I updated the firmware and didn't realize it.  Now I see that Pos hold is even greater.

             Now I am able to use pos-hold and love it, but can only set it up using APM Planner.  Thats OK, but would much rather be using MP..

            The purpose of the me posting this is to try to get to the bottom of how I can get MP working with regards to the modes list, which so far I have been unable to figure it out.. Open to any suggestions.

            • Developer

              I can't see the attaches/images in you post I'm afraid but I get the idea.  So it seems like you have a recent version of mission planner but somehow it's got the wrong parameter information.  I really don't know how that can happen and, at the risk of passing the buck, it's really not a flight software issue.  It's certainly an MP issue.  You might want to try uninstalling it and reinstalling it again from an msi file, then make sure to go to help, check-for-updates.

              Failing all that, I'd say raise it in the APM Forum or MP's github issues list.

              • Thanks Randy.

                I will check in with the MP list.. I have tried uninstalling MP, cleaning it completely, then re-installing it, that failed so I installed in on a windows 7 virgin PC, (never had MP on it) and I get the same results.  in the drop down "position" appears, but "Position Hold" doesn't.

                Thanks for your help and I understand your focus is on the flight software and you are doing a great job of that!

                Thanks

                RE

                • Hi Richard,

                  Had the same problem myself and just fixed it, it would appear to be an issue with the mission planner installer not correctly installing everything.

                  As you have done I uninstalled the old mission planner, removed the residual "Mission Planner" directory from Program Files and then installed Mission planner as new.  This resulted in me not being able to see PosHold as an available flight mode (I have tested versions 1.3.17 and 1.3.19 and both had this issue).

                  I then uninstalled and cleaned again and went back to an older version of Mission Planner (in my case version 1.3.10 as I had it in my downloads folder already).  Once this was installed I started it up and let it do its auto update (which took a little while), and it is now back at version 1.3.19 but this time PosHold is available (I have yet to test it in the air mind).

                  So it would seem that the Mission Planners auto update is installing/configuring something that is not in the downloadable  MSI.

                  Hope that helps,

                  S.

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
gotham liked gotham's profile
Dec 3, 2020
More…