ArduCopter-3.2.1 Beta Testing

ArduCopter 3.2.1-rc2 (release candidate #2) has completed beta testing and has been released as the official version available through the mission planner and other ground stations.

Changes from AC3.2 are listed below and in the ReleaseNotes:
1) Enhancements:
    a) reduced twitch when passing Spline waypoints
    b) Faster disarm after landing in Auto, Land, RTL
    c) Pixhawk LED turns green before arming only after GPS HDOP falls below 2.3 (only in flight modes requiring GPS)
2) Safety Features:
    a) Add desired descent rate check to reduce chance of false-positive on landing check
    b) improved MPU6k health monitoring and re-configuration in case of in-flight failure
    c) Rally point distance check reduced to 300m (reduces chance of RTL to far away forgotten Rally point)
    d) auto-disarm if vehicle is landed for 15seconds even in Auto, Guided, RTL, Circle
    e) fence breach while vehicle is landed causes vehicle to disarm (previously did RTL)
3) Bug Fixes:
    a) Check flight mode even when arming from GCS (previously it was possible to arm in RTL mode if arming was initiated from GCS)
    b) Send vehicle target destination in RTL, Guided (allows GCS to show where vehicle is flying to in these modes)
    c) PosHold wind compensation fix
    d) prevent infinite loop with do-jump commands pointing at each other
    e) pixhawk memory corruption fix when connecting via USB
    f) vehicle stops at fence's alt limit in Loiter, AltHold, PosHold (as it did in AC3.1.5)
    g) protect against multiple arming messages from GCS causing gyro calibratoin failure

Thanks to Raph for the video.  This is actually a video from AC3.2 until we have one specific to AC3.2.1.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Position is an old flight mode that has been removed.

          If you load up mission planner, press CTRL+F then click on Param Gen it should download all the latest settings for mission planner including being able to select Pos Hold.

          You will probably need to restart mission planner after giving it a few minutes to download the up to date parameter file.

          • That did the trick. Thanks again!

  • Is the relay servo function somehow broken now? I'm using A9 on APM and the "relay" option works fine and I can set the duration but when choosing "servo" for A9 it outputs nothing...

    What am I missing? Previously I had this working...

    • Developer


      I actually didn't think that A9/RC9 worked as a servo output on the APM with Copter ever.  RC10, RC11 should work as will the RC outputs on the back.  I see at least the MP's camera shutter set-up shows RC9 as an option so we should remove that.

  • I think I just bricked my Iris+ trying to upgrade to 3.2.1

    I've started update thru Mission Planner and it errored before finish.

    Now when I connect it detects the board in the connection drop down but timeouts to connect.

    Also, when pixhawk is powered it doesn't play any music as before and safety switch keeps blinking rapidly.

    How can I unbrick pixhawk?

    • Developer

      Yes, re-installing the firmware is the key but you may need to be careful on the timing of when you plug in the board and when you push the button on the MP.  I'm not totally sure but I think you can do it by:

      1. plug in the board and very soon after click the upload button

      2. the MP will likely freeze but just unplug the board and plug it in again and it'll likely upload

    • Yeap, worked. Thx
    • Developer

      Just re-install the firmware.

  • MR60

    Hi Randy,

    Here a log of a test flight made today with the 3.2.1 release on an octaquad. The log autoanalysis displays all good, except for PM Sloop loop (max 11,95%). Is this a red herring or an issue I should fix, and if yes what could be the issue ?


    2015-02-13 09-32-09.bin

    2015-02-13 09-32-09.log
This reply was deleted.


DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support.
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17