ArduCopter-3.2 beta testing

Warning #1: PX4/Pixhawk users upgrading from AC3.1.5 (or earlier) may need to re-do their compass and accelerometer calibration because AC3.2 also uses the backup compass and accels.  Pre-arm checks have been added to ensure this has been done.

Warning #2: on the APM2.x the logs must be downloaded using MAVlink instead of the terminal.

AC3.2-rc14 is now available for BetaTesters through the mission planner’s Beta Firmwares link.  The full release notes can be found in ReleaseNotes.txt and changes from -rc13 can be seen below.

     Feel free to raise issues found during testing on this discussion or in the new support section in the APM Forum.

     It’s a big release with “the onion” restructure and a bunch of new features (including these 57 closed items) so we need to re-test almost everything including all flight modes, all mission commands and all the new features.  Marco and I will be maintaining (and adding to) this testing list.  Issues reported will first be checked by Jonathan, Marco and I and then confirmed bugs/issues will be put on the github issues list (and then hopefully fixed).

     Thanks especially to the beta testers who put their copters at risk testing each release.  Enjoy!

Changes from 3.2-rc13
1) Safety Features:
     a) fail to arm if second gyro calibration fails (can be disabled with ARMING_CHECK)
2) Bug fixes:
    a) DCM-check to require one continuous second of bad heading before triggering LAND
    b) I2C bug that could lead to Pixhawk freezing up if I2C bus is noisy
    c) reset DCM and EKF gyro bias estimates after gyro calibration (DCM heading could drift after takeoff due to sudden change in gyro values)
    d) use primary GPS for LED status (instead of always using first GPS)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • It is important to calibrate your ECS, the easy way is all at once

      and do the full harware calibration

      • Alas, I have done both many times, but thank you!  I have calibrated the ESC, per both the "all at once" and the "individual" procedures prior to flying with 3.1.5, and they worked normally, and it flies perfectly.  I did not think they need to be re-calibrated just because I load 3.2-rc3 or -rc4, so I then load 3.2-rc3 or -rc4 and they do not work.  I then reload 3.1.5, without ESC re-calibration, and they work.  If I re-calibrate ESC with 3.2-rc3 or -rc4 loaded, by either method, the calibration appears to work, but the strange motor behavior is still there when I connect LiPo and try to fly.  I am fairly sure the ESC re-calibration worked when -rc3 or -rc4 were loaded because I can reload 3.1.5 without re-calibration after trying (and failing with) -rc3 or -rc4 and the ESC behave normally and it flies perfectly. The ESC simply do not work properly when -rc3 or rc4 are loaded.

        • that happens because the default pwm output values are a little bit different on each version, so when you power the copter with the new version, the ESC don't like the new values

          • I tried someone's suggestion, hold down safety switch when applying LiPo power. Did not work. So I tried it re-calibrate ESC all at once. Didn't work. So I tried all at once calibration, holding down safety switch with throttle up to start calibration. Didn't work. So I tried it several more times, each time holding down switch when applying LiPo power, alternating between throttle up and down. ESC never entered calibration mode. Suddenly,once when the throttle was down, it armed and all motors ran! Kept it hooked up, took it out, had my first -rc4 flight, amazing! Have not been able to get it to arm and turn props since... Many attempts to repeat - no go... Might be a race condition in the software somewhere...
            • Developer

              Hi Mike,

              There really shouldn't be any need to re-do the calibration from 3.1.5 to 3.2.  No offense to Javier but as far as I know, there should be no changes to the pwm being output with each version.

              I wonder if it's possible that it's tripping over an arming check.  If you connect it to the mission planner and then arm it (without the battery connected) does it arm?

              • Hi Randy! Just loaded -rc5, ran through all set up's, cals, etc., it arms normally and flies perfectly! Detailed testing and tuning commences... Thanks, sincerely great work!
              • Thanks Randy, tried to reply over iPhone, not sure if it worked, sorry if there is a duplicate message...

                Yes, just checked again, it always arms via MP without LiPo, no warning messages.

                I have since been able to get it to arm and fly twice (out of 50 tries) by some combination of holding down the safety switch for a period of time when and after connecting the LiPo. It does not seem to be deterministic, or I have not found the correct pattern. I can tell when it will work because of the beeps. No beeps, no work, 2 beeps, it flies!

                When it flies it is amazing, hats off to the Dev's!
                • Hi Mike, i am just curious... when you fly do you first connect to the Mission Planner via telemetry? Simple because, i think if the copter doesn't arm there should be message in the Mission Planner showing why arm can not be done....ex: bad compass health, magfield, etc. 

  • Hi Randy. Thanks for updated wikis and 3.2r4. I have put in several hours of flight time using Pixhawk+EKF in both my hex and quad and have enjoyed every minute of it..Fantastic..

    I purchased a MB 1242 IC2 sonar but using the parameter values in the wiki and connected to the IC2 connection strip along with the compass and ext LED. There is no indication of function under the MP status tab with sonarrange and sonar voltage both 0.. I wired the 1242 with shielded cable and the noise filter..

    I guess my question is-- rc4 capable of IC2 sonar?


    • Hi Edward,

      your params seem good but I think you should not use a noise filter with the I2C one as noise filter is designed for analog sonar.

      As you can find in the I2C wiki, wiring is direct on the I2C port...

      And normally both I2C and analog will work with 3.2-rc4.


This reply was deleted.


DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support.
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17