Hi Guys

 

I seem to have a problem with me copter  and I cant put my finger on it, I have built a few Quads before and have had no problem with them but my own copter for some reason has given me problems for past few months now, I first loaded the 2.37 beta on my Quad and had problems with the right motor not reacting to any movement of the quad, ended up replacing motor, ESC,and resoldering the port on the PDB still had a problem, then I tried a 4S 5000mah pack just for the heck of it, and the problems was at the end ? that ment it was probably a bad battery and I order new battery packs for my copter, recieved them and used them with no problem after that. since then i have updated on weekly bases and the problem has returned.! this time I tried three different battery packs and the problem still presisted. Im currently flying .45 code base and have some reaction out of the right motor BUT when launching the copter spin up and takes of in a direction of its own(probably due to underperformance of the right motor) any thought of what it can be and what to check ? I tried two different APMs aswell same problem. still using 1280 board

 

thanx in advance.

Johann

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

     

    Did you tried motor test ? (CLI, setup, motors). Is it ok ?

     

    then i would try to connect your faulty ESC / Motor directly to receiver Ch3, and if possible connect another good ESC / motor with a Y cable and compare.

     

    If this test is right, then you certainly have a wiring problem, or a ground loop somewhere. Eventually try to use a BEC to power the APM instead of the ESC BEC (disconnect all red wires of ESCs if you try this).

     

    If this still does not work, i would take the right motor / esc and exchange it with left motor / esc to isolate the problem.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
16 hours ago
DIY Robocars via Twitter
16 hours ago
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…