I just received a octa copter bought from DIY Drones.

i am using Futaba 8TFG and 4000mAh 20c battery.

plugged the board to APM, get the connection and setup.

but there seems not to be enough rpm on the motors.

it just does not lift?!

also when I charge the battery, the charges shows 12v buton the mission planner it shows 7.9V and 25A.

it is obvious that I am new to this, so would appreciate your help, i am dying to get this beauty off the ground.



Views: 2487

Reply to This

Replies to This Discussion


Welcome to your new hobby!! I don't know your specific kit but in general you have to do some first time calibration (ESC,Transmitter, Ampere/Voltagemonitoring,Magnetometer, Accelerometer etc)  and learning in your Transmitter. Don't forget to set up your Radio/APM combo for a proper failsave action - you never know. This is setup is described in the wiki. Some things there are outdated, but in general reading the manual of your Radio and the APM-wiki will pay off and save you from great trouble (broken copter, cut fingers, fly-aways etc)! It is too much to put in one post.

So long

Kraut Rob (aka Crashpilot)

Have a few questions.

Is your battery a 2 cell or 3 cell? 7.9v is proper voltage for a 2 cell while 12 would be a 3 cell. Curious with 8 motors I wonder if your battery it strong enough for all of them.

Did you calibrate your radio inside MP? May not be getting full throttle.

Hi Kraut

thank you for the tips

I will go over every thing again


Hi Jason,


sorry for the mistake, it is a hexa copter

i bought the complete kit from DIY drones including the motors, ESCs, APM 2.5, ....

the battery is 4000mAh 3S. I also tried charging 2x 2200 mAh 3S batteries and connected in parallel.

again the charges when finished charging says 12V, but the mission planner show around 8V?!

I also did calibrate the radio in the mission planner.


i was playing around and just realized:

- the in full throttle, the props are now spinning very powerfully

- but when playing with roll, it lifts the hexacopter to left or right and with side motors having much more thrust than full throttle$


I think you have the same understanding problems i had when i started. Your Voltage Issue: Is in reality non - existent: Because the battery voltage is scaled down by resistors ("voltagedevider") to your apm inputports (12V would burn them). So the missionplanner has to know this voltagedevider to calculate the proper Batteryvolts. I found the current missionplanner to be a little buggy in this regard and i ended up typing the devider in the parameterfield manually. I also use a cheap liposaver (makes loud beep at 3.5V/cell) to protect my lipos from undervoltage (otherwise renders them useless really fast!).

Your throttleissue is also caused by the "nature" of multicopters. If it would be possible to max out all motors with your stickinput it would crash because there is no headroom for the flightcontrol anymore to level your copter. Even at "full throttle" there must be some freedom for flightregulation left.

Next thing: Don't judge a copter standing on the ground. Due to the FC-regulation not all motors will run at the same speed.

I hope i wrote this understandable. My English is not the best. It improves in the pub with 2 beers :) .

So long

Kraut Rob

One thing that got me perplexed for a few moments when I assembled my Hex was it just wasn't lifting even at full throttle


Then i realised i got the props in the wrong order.  The CLOCKWISE prop normally has an R on it if thats any help.


Full directions here:


All ESCs calibrated, props in the right direction, calibrated radio inside MP,.........
Still no luck!
In order to isolate the problem, i disconnected one of the motors from APM and connected it directly to the throttle channel of my receiver, moved the throttle up and wow, it went to full thrust and the single motor lifted one side of the hexacopter!
So it seems battery and ESC is ok, only it the proper signal is not getting generated by the APM

 I am having the same issue although it is on a custom build.


It is as if the throttle is not getting full power (from what I can tell only about half the power possible). When the I plug a single ESC directly into the RC output it has enough lift to tip the Hexacopter over and I have run the same setup with KK2.0 board previously (just changed over to HK 30A esc flashed with Simonk ) and it flew around no problem. I have over 7kg of possible lift and the Hexacopter only weighs in at 2.2kg. Is this a 2.8.1 firmware issue (no previous posts with anything like this that I can find)?


If it wasn't for the fact that I am no stranger to ESC calibration and setting up "custom" PID settings for custom builds I would say that the radio or ESC's are not calibrated properly but this does not seem to be the issue, is there a setting in the PID that I should change, something like the P value under throttle?


I am going to try it in Acro mode this afternoon to see if there is something going on with the stabilization which is reducing overall power output from the motors when “increase altitude” is given. As far as I can tell the motor speed should continue to increase until lift-off or they reach maximum power output when positive throttle is given in stabilization mode. The heavier the load on the Hexacopter the faster it will spin the motors to achieve lift-off. At present maximum throttle is given and the motors only achieve around 40% of maximum speed and this is not enough to get off the ground.


I wonder if the ESC’s have a high voltage cut-off set so when all the motors start to spin up and there is a voltage sag the ESC’s are having their max throttle choked back to like 50%, I know it’s not the batteries or wiring as the same setup with a KK2.0 board and 30A Turnigy ESC ran fine and happily carried and depleted the 16,800mah of batteries. I went away from the Turnigy ESC I was using as 2 of them cooked off and the rest of them got superheated even after only a 10min run, that and I wanted the better response timing of the Simonk flashed ESC’s.


On a side note, what is the best frequency output for these ESC’s, 400hz?

Let me know if you have found a solution, two weeks now, eager to fly but have not found the solution yet!

Yeah, did not get a chance last night to test the acro-mode.

Just wondering what radio you are using? I am using a Turnigy 9X with the arducopter, I previously flew the Hexacopter on a Aurora 9 (1000 X better than the turnigy 9x), but due to the head tracking not being able to be setup on the Aurora I am forced to use the Turnigy 9X.

When I calibrate the Turnigy 9X it does not use the entire calibration zone, I will also try extending the endpoints on the Turnigy 9X although I believe the adjustment is very limited in comparison to the Aurora 9.

I put the hexacopter into acro mode this afternoon and it made little difference. I then went through the auto-calibration again and noticed the beeps did not line up with the manual for this. After playing around and trying to redo the calibration many times I decided to go to manual calibration.


I unplugged the throttle channel from the TX, then plugged in a servo lead extender (with the red wire pin pulled out) and manually went through and calibrated each motor individually.


BINGO, working like a trooper. It seems that when you calibrate the throttle through the ardupilot, it only passes through the signal increase upto half throttle, leaving the output from the ESC's to be no more than half.


try the manual calibration and see what happends

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service