Hi,

We've just received our arduimu v2+, we've got problems to upload the arduino sketch to it.

  • we're using the FTDI cable from DIYDrones shop, with the right colors at the right place (black near GPS).
  • when uploading to the board, the code is compiling in Arduino, and after a while, we get this errror (on mac):
avrdude: stk500_recv(): programmer is not responding
avrdude
: stk500_recv(): programmer is not responding
  • on windows, we've got this error:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude
: stk500_disable(): protocol error, expect=0x14, resp=0x51
  • the leds blink like there is a reset occuring, and the code seems to start just after (red light switching on on movement).
  • I've tried the reset technic, by pressing the reset button at various intervals after the code has compiled, from the Ardupilot FTDI Firmware Programming video.

Would you have some advices for us to upload arduimu firmware?

Thanks a lot,

Alex & Marco

Views: 712

Reply to This

Replies to This Discussion

hi alax, i am also getting the same error while uploadin in windows os.on connecting ftdi cable to my laptop green and yellow lights r continuously on and red gets on after movement.i checked all the setup and setting, i dont know what is the problem.pls reply if get any solution on this. Thanks.↲Dhiraj.
Hi Dhiraj,

We've solved the problem by using the FTDI Usb Explorer board from Sparkfun, maybe the FTDI cable was not working properly, we need to test with another USB FTDI cable to be sure on this point.

Good luck,

Alex
thanks.for your help alex
Hi Alex
Can you please be specific as to which exact usb explorer board you used.
Did you use the 5V version or the 3.3V? Your help would be greatly appreciated.
Ali

I have the same problem. Strangely the cable seems to work fine to program the Ardupilot.

Same with me. Any ideas? I'm using 5V version of cable.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service