Good day everyone, My ArduIMU+ V3 board arrived this morning, then I accidentally put the FTDI cable in reverse, then the "X LED" on the board keeps on blinking, but not like other LEDs the blinking "X LED" is Dimmer..

I tried to upload, DMP code for the ArduIMU+ V3. But its stuck on "Uploading to IO Board",first the Y and Z LEDs Light up, then after it goes off then I waited for a long time still nothing happens. Did not complete the upload, stuck on  "Uploading to IO Board".

What are your suggestions about my problem. Thank you so much

Views: 2176

Reply to This

Replies to This Discussion

I think you have the wrong board type selected in your Arduino IDE.  I've definitely done that a few times and it acts like you describe.

Thanks Randy, But still, I can't upload the code on my ArduIMU V3, I chose the Arduino Dueliminove w/ ATmega328. 

Joseph ,I am also having the same issue.I have tried Arduino 022 and 1.0 ,selecting Duemilanove 328(and also Pro Mini

5v16Mhz 328). When I upload a Sketch the red and blue leds flash briefly(i think in response to DTR being set) but It appears the bootloader does not connect .The upload hangs until the arduino reset is pushed one or two times.

      I have limited experience with Arduino ,both my ArduIMU+ V3 are behaving the same way,but I can load my test Sketch

onto a ProMini board.I can also read the serial data from the pre installed test sketch.At this point I believe there is an issue

with the bootloader.I am open to any ideas ,thanks.

Hi all,

 

I have the same problem, how did you solve it ?

 

Thanks in advance, Marco

I just got my V3 and have the same issue.

It dumps ascii data at 115200 baud.

When I hang a scope on the comm lines I see that the processor is never getting into it's debug mode to allow reprogramming, it just keeps running is application code. I'll investigate tomorrow why this is happening.

Hi Emil,

Currently my problem is not solved but I was able to understand that my IMU V3 is only able to send data thru Serial, and is not able to receive data. To check this, I made a small sketch "Echo" which should receive data on Serial and print it back to Serial. I can upload it using the an AVR programmer, it's available in the file menu of the Adruino IDE.

Here is the sketch,if you want, you can upload it, and in the serial consol, check if what you type in is sent back in to the consol :

#include <FastSerial.h> // ArduPilot Fast Serial Library

#define RED_LED_PIN 5
#define BLUE_LED_PIN 6

FastSerialPort0(Serial);

void setup() {

   pinMode(RED_LED_PIN, OUTPUT); // red led
   pinMode(BLUE_LED_PIN, OUTPUT); // blue led

   Serial.begin(115200, 128, 16);
   Serial.println("Echo");

}

void loop() {

   delay(100);

   digitalWrite(RED_LED_PIN, HIGH);
   digitalWrite(BLUE_LED_PIN, LOW);

   while (Serial.available() > 0) {
       digitalWrite(RED_LED_PIN, LOW);
       digitalWrite(BLUE_LED_PIN, HIGH);
       Serial.print(Serial.read());
   }

}

Success!

This is what I did.

Using version Arduino 1.0.1

Arduino Duemilanove w/ ATMega328

I modified ArduIMU328_V3 which was what was loaded initially, I just changed some of the text it was dumping and lengthened the delay. I did this just to make sure I was actually programming it! :)

I then held the reset button on the board and let it compile and link, as soon as it said it was uploading I released it, presto, it worked !!!

I've done this repeatedly so it seems to be a viable method.

Hope it works for you guys.

Well done Emil.

That sounds like there's a hardware issue with the reset line on the 328 not being properly connected to the ftdi cable...something for the 3dr guys to take a look I think.

I don't recall if I ever saw the reset being pulled low when debugging which as you implied does the button pushing for you although I may have missed it, I'll check again tonight. I do remember sometimes seeing it being pulled low earlier in my investigation but I never went back to see if it's actually happening right before it starts the upload.

I'm not using the standard cable, I just have a USB to TTL converter based on the CP2102 and hooked up the 5v,Gnd,Tx,Rx,Rst lines.

The only other thing I was thinking is the code in the chip dumps a bunch of data at 115200 baud every 50ms, and it may be overflowing the receive buffer on the host device causing a problem. I'll load a simple program and see if it will work automatically and look at the reset line.

Either way I was able to get it working, time to move on to the next step !!!

Did some research last night and saw that the Reset line is never pulled low. In the documentation it says that the "RTS on close" option must be set, I think this is the problem. When I go to advanced options on the port, it doesn't give me that option. The only options are Use FIFO buffers, Set the Receive and Transmit buffer size and set the COM port number. It's like the old XP type config although I'm running Win7-64?

In conclusion I don't think there will be anything wrong with the board once I figure out how to set the RTS on close.

Thanks

I am also having a similar problem. Has anyone solve the problem?

I can read the data from COM port and compile the sketches (ArduIMU_1.9.8) on Arduino IDE 1.0.3. However I cannot upload data to the ArduIMU V3. I need to press the reset to terminate the uploading process. It returns the following message in the command;

"  avrdude: stk500_getsync(): not in sync: resp=0xbe   "

Using a FTDI cable from Sparkfun - FTDI Cable 5V VCC-3.3V I/O (https://www.sparkfun.com/products/9717)

I ticked "RTS on close" in the option as Emil stated.

If anyone could share any idea, it will be great. Thank you very much.

In my previous response:

"I then held the reset button on the board and let it compile and link, as soon as it said it was uploading I released it, presto, it worked !!!"

As I remember the timing of releasing the button is critical, too soon or too late and it will fail.

Release the button as soon as you see the uploading message.

Hope it works for you.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service