ArduPilot 2.46 work out brillient but never ok wz 2.5.02 or 03

I used to fly Ardupilot with 2.46 and it works without any problems and very happy about its performance but recently I have been upgrading from 2.46 into 2.502 or 2.503 but never work it out. It seems that CH1 and CH2 serve plus can not be detected. I use Ardupilot_25_Radio_test test it and finf out all CH1 and CH2 plus all under 1000. I move to CH1 rudder left @857, Center @850, Right @853 but while I move CH1 to left @857, my CH2 also move from 959 to 1028.....that is a very strange movement as I did not move CH2. When I only move CH2 up, center, down, it did not show any signs of moving and stay @959.

 

There are more problems when I load 2.5.03 such as GPS blue LED false luck all the time, CH1 serve steady twich @ FLY_BY_WIRE ; FLY_BY_WIRE mode has no response from radio movement. Switch to FLY_BY_WIRE and STABILIZE mode sometimes  cause ardupilot freeze. I am thinking that it looks like my Radio is not in right setting.

 

I am using JR PCM9X and JR SPCM receiver  R900S, ardupilot 328, version 1 shield, em406, XYZ sensor. Soldered both the jump wires on the bottom of the ardupilot.

 

My Ardupilot_25_Radio_test Head file setting as following:

#define SHIELD_VERSION 0

#define AIRSPEED_SENSOR 1

#define GPS_PROTOCOL 1 // 0 = NMEA, 1=SIRF, 2=uBlox, 3 = IMU Choose protocol

#define MIXING_MODE 0 //Servo mixing mode 0 = Normal, 1 = V-tail

#define ENABLE_Z_SENSOR 1

#define XY_SENSOR_LOCATION 0

#define SET_RADIO_LIMITS 0

#define SET_RADIO_TRIMS 1

#define CH1_MIN 1220 // (Microseconds) Range of Ailerons/ Rudder
#define CH1_MAX 2043 // (Microseconds)
#define CH2_MIN 1041 // (Microseconds) Range of Elevator
#define CH2_MAX 1765 // (Microseconds)
#define CH1_TRIM 1500 // (Microseconds) This is the resting position for your sticks - 1500 = no trim
#define CH2_TRIM 1500 // (Microseconds) Trims are normally set automatically in setup.
#define CH3_TRIM 1015 // (Microseconds) Trims are normally set automatically in setup.
#define THROTTLE_IN 1 // (boolean) Disables throttle when set to 0
#define THROTTLE_OUT 1  // 1 = throttle, 0 = no throttle at all! (good for saving fingers on the bench.)
#define FAILSAFE_PWM 950

 

Views: 215

Reply to This

Replies to This Discussion

Use the latest code (2.5.04 or 2.6) and try Radio Type 1

//3-2
#define RADIO_TYPE 1 // 0 = sequential PWM pulses(Fasst, Spektrums), 1 = simultaneous PWM pulses (Corona RP8D1)
Gus5610,

I'm using the same setup as you.
JR PCM9XII and JR SPCM receiver RS10DS ardupilot 328, version 1 shield, em406, XYZ sensor, but with the 2.5.04 code. The stabilizer mode rock!!

Today I give a test Auto & Fly By Wire mode. All work but my ez* keep descending. In RTL loiter it also descending.
But overall the code works for me.
Chris & Saifu

Thanks for helping. That sounds promising. I will try it this weekend and report it.
Hi

I have the very same setup as you have. Also have the same problems as you. I do however get the right readings from the servo's. Switching between Stabilize and RTL also made the ardupilot freeze. It even went into a mode(which I could not exit) which would give me controll of the rudder and elevator but not the throttle while it tried to stabilze like a autopilot who had to many drinks.

I've tried to get this to happen again but it has only done so twice in the 5 times that ive flown it with 2.5.04.

I hope to get the problem solved. Jason and Chris also offered to help :) Will get them to do so shortly...

Got a new radio today.
Same advice. Try Radio Mode 1 if you're having trouble with Radio Mode 0.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service