Developer

ArduPlane 2.40 released

ArduPlane 2.40 has now been released. Many thanks to everyone who gave flight test feedback on the beta release!

Note that ArduPlane now uses MAVLink 1.0, so you'll need to update your Mission Planner to the newer version, which supports that. You'll find it in the same directory as your current Mission Planner, in a file called ArduPilotMegaPlanner10.exe

For a list of feature changes, see the ArduPlane-2.40-beta announcement. Since the beta the following things have changed:

  • auto-configuration of UBlox GPSes. It should now be possible to attach a UBlox GPS in just about any state and the APM GPS code will re-configure it appropriately. The configuration isn't saved, so if you power cycle the GPS it will revert to what was set before, but it should now be possible for the APM to use a UBlox in factory default config. It's still a good idea to setup your UBlox correctly (38400 baud in UBX binary mode) as that will make the detection faster on startup, but it should work regardless.
  • updated Camera and Mount control code from Amilcar Lucus and Greg Fletcher. These are not enabled by default, and I have not tested them myself, so I'm hoping Amilcar and Greg will be able to answer any questions that come up. Many thanks to Amilcar and Greg for all their work on this!

Happy flying!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Any Idea when V2.5 will be out? I heard that it’s getting close.

  • How can i get RSSI information trough a port on MAVLink.

    How would you do it? :)

  • Could someone upload a parm file of a usual flight?
    I would like to test my minimosd code.
    THX

  • Why is elevator reversed in FBW_B?

    How can i make it work normal?

    Have i misunderstood something? :)

  • In this version there's still the same issue I don't understand like in previous ones. When looking at calc_nav_pitch() there is a command

    nav_pitch = -g.pidNavPitchAirspeed.get_pid(airspeed_error, dTnav); (2 parameters call)

    However, get_pid definition is

    PID::get_pid(int32_t error, uint16_t dt, float scaler) (3 parameters definition)

    How can it be like this? Can you explain me?

  • Also,

    I use a modified code for MinimOsd. Added a few things.

    Now i can't use it. I would put my code in the so9urce, but i can't download the new code. Only the old can be found.

    Because of this, i have to go back to 2.34. :(

  • For me, manual level does not works anymore. It tells me; "Failed to level: AP 2.32+ is required"

    If i can level it somehow, i will try 2.40 tomorrow.

  • Hi all, I uploaded the 2.4 in my APM arduplane 1.0 2560, I've also loaded the file. param used in my skywalker. But something strange happens when I disconnect the battery and re-plug. PIDs return to their initial default confuguracion. configuration file .param disappears.

    anyone knows why this happens?

    thanks

  • Thanks all for the tests!

    I use manual level and since upgrading to 2.4 today I get the following error when trying to do level:

    Failed to level: AP 2.32+ required.  This is new and worked perfectly on 2.34.

     

    Any ideas?

  • I've just recently delved into ArduPlane. I'm intending to install it in the HK EPP FPV frame and would appreciate any guidance on tuning. I've heard it's similar to the Skywalker, but I don't know how the default parameters will work right off the bat. Does anyone know of some reasonable parameters to start with? Thanks!

This reply was deleted.

Activity

DIY Robocars via Twitter
Jan 28
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
Jan 23
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
Jan 23
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
Jan 23
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Jan 22
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Jan 21
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Jan 18
DIY Drones via Twitter
Jan 18
DIY Robocars via Twitter
Jan 18
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
More…