Arming with Ground Station ended in crash (ArduCopter 2.9.1b)

Hello all,

I did a test with an auto mission and the ground station today.

It was a simple mission with some waypoints.

Something similar worked already before.

The only difference was that I armed the coper (Hexa) in the "Actions" tab and set the Auto mode there too (on ground).

After rising the throttle a little the mission seems to start but it was just a loiter above the start point.

I decided to turn off the auto mission and land but when I switched to a different mode (Alt hold) with the remote control the motors stopped and the thing came down (flipped) from about 15m :-(

Is this a known problem?

What went wrong?

Regards,

Bernd

Views: 427

Reply to This

Replies to This Discussion

No logs provided so it's hard to be sure but I'll bet the throttle was at zero when the copter was switched to alt-hold.  There was a warning in the original 2.9 release thread (but sadly not in the 2.9.1b release thread) that warned of this issue.  If you'd raised the throttle above zero it would have recovered.

Hello Randy,

here are the logs.

I am not sure were throttle was when it happend, but for me it seems that it was above 0.

Does it mean that it falls down uncontrolled or just very quickly?

In my case it was definitly uncontrolled. Flip, over and out :-(

The data is hard to read in detail.

Please have a look.

Thanks,

Bernd

Attachments:

Bernd,

     Ok, so yes.  the throttle was zero when switching modes.  Top graph shows the altitude.  Middle graph shows the throttle and it's pretty much zero for the whole flight.  Bottom image shows the line numbers of when the copter was switched between various modes.

This issue is fixed in AC3.0.1 of course.  Also a ground station failsafe is added.  I guess in this case you're not using the transmitter but just a ground station?  It's a bit dangerous to do it this way with 2.9.1b because if you lose contact between the ground station and apm there's no way to bring the copter back.  In AC3.0.1 there's a failsafe so it will switch to RTL if you lose contact.

Hello Randy,

Thanks.

I had the transmitter beside me. Without it I would not trust the system.

But it did not help me in this case ;-).

And I do not know how to activate the auto mission without the initial throttle anyway (?)

It seems that I put it back to 0 when the copter started - bad, bad.

Is there a reason why the mission was not really started - this was the initial problem?

Maybe this is a good reason to switch to the AC3 now.

Ok, lets say when the copter is ok again.

By the way - is there a page were all the really dangerous "no go's" are listed?

I think it is impossible to go through all the discussions that point out such issues.

Bernd

Yes, as you say, the mission wasn't restarted.  It was a hole in the logic for "auto armed".  This "auto armed" check stops the copter from taking off until you raise the throttle.  So you've probably noticed when starting auto from the ground, it will sit there until you raise the throttle.  It's this check that causes that.  The problem was that we were letting the auto armed flag go to false even if you were already flying.  That's fixed in AC3.0.1

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service