autopilot goes crazy

Hi all,

First a little background.

Ive been using ardupilot for a while now. I had the original working well, and had flights out to 9km with great success. But then I updated the software and had to start all over. No problem I thought, a good excuse to move to the mega platform.

 

I now have the ardupilot mega/oilpan and ublox GPS in a skywalker currently with the latest code.

 

My problem is that although the plane flys fine in stabilize and FBW, as soon as I try auto it tries to destroy itself. It goes full throttle and drops the nose. Things get ugly very quick as you could imagine. Also it doesn't appear to even turn towards the way point.

 

The GPS seems to work OK, as it reports my current position correctly in google earth, and I can upload waypoints, and check them. 

 

I must be missing something obvious, but not to me right now. If I had to guess I would say a faulty GPS, but as mentioned it appears to work fine.

 

Any ideas on where I should start looking? I'm a little lost.

 

Cheers

Jamie

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had this happen to me as well. I couldn't recover though and I gave up on the project (this was my 2nd IMU compromised in a hard crash).

     

    Just out of curiosity, what transmitter and receiver are you using?

  • Hi Jamie

     

    I have no solution for you, but just want to let you know that you are not alone with this problem. I have the latest APM and Mission Planner versions and tried various settings. Waited a long time before launch to ensure GPS lock so I was sure that home coordinates was correct.

     

    For me it helped to pull back the elevator (nutching) to help the Skywalker to get on track. Obviously this should probably not be needed. Just a workaround.

     

    I will let you know as soon as I find the problem.

     

    Regards,

    Jesper

  • Fabian, thanks for the reply.  I wondered the same thing, but Chris mentioned earlier that the log won't show No. of sats.


    What did you mean by "alternating too" ?  Did you see somewhere that the gps got lock then lost it ?

     

    My suspicion is the GPS also, but I'm really looking for evidence before I go out and replace it.

     

     

  • Thanks Chris, just wasn't sure if it was something I had done, and whether it was related to the issues.

     

    How do I go about getting a log?

  • 3692238804?profile=original3692238493?profile=originalHi Chris,

    I have included a snapshot of the config also. Just in case its helpful.

    Cheers

    Jamie

     

  • Chris, I had tried RTL also, but it reacted the same.

     

    Do you mean a screen shot of my waypoints ?

     

    No airspeed sensor fitted. I used FBW A I think. The one with manual throttle control.

  • Developer
    do you have an airspeed sensor? also was it fbw a or fbw b?
  • 3D Robotics

    Please upload a screenshot of your mission plan.

     

    Also, you should always start with RTL to test GPS etc.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…