Bad ublox module? APM and ublox wont blink blue.

Hello.

I have had my APM 2.6 with the ubox now for a while, and are finaly starting to figure hows it works.

I have always had some issues with my GPS. At first i saw "bad gps helath" in mission planner but thought that it was calibration or that i was inside house issue.

I have always had some problems with RTL to. It sometimes work, and sometimes dont. I thoguht this had to do with max tilt values and it was windy.

Now latley i been trying loging so i have had the apm connected to my pc alot. Then i noticed that it took a long time before the blue led on my ublox startet to blink (with the error bad gps health on my mission planner). It could also start blinking and then stop blinking (and bad gps helath appear in mission planner).

Yesterday I removed the gps cable, messaured it for any fracture, but it was ok. When i inserted the wire and connected it with the usb cable it was dead. It has only the red light, the blue led wont blink. Also the APM blue led wont start, and the mission planner says no gps.

Also the log, it reports big hdop values. Im still learning about the logs, and i tried the MP "auto analysis" but it say bad length si i have to use another program. So i use "APM flight log analysis". And that program says "WARNING: A HDop of greater than 2 was detected during this mode." The max value is from around 5 and min value is around 2.09

Can it be, as i have started wondering,  a bad ublox module?

I also messaured how much volt that the apm sent to the gps, and it was 4.8v. I have read alot latley, and i think i remember that the gps should have 3.3v, but i cant find that source.

Anyone have any tips... please help :)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Finaly went to the post office to collect my new ublox.
    This one seams to work much better. I now got the blue light. I have testet the APM connected to the MP 20 times, and i have seen the bad gps health a couple of times, but it finds satelites very fast (20 secs) and finds 10 satelites inside my house.

    However... I testet the RTL function in my plane, and that is not working so far. I have tested it 10 times, and it came back home 1 time. It was quit windy, and it seams that it tried to go home but it just couldnt turn enough. So im going to try the autotune and see if i can give it more turn possibility (it kind of seams stuck on very soft turning now, and when it is wind it will rather drift away).

    • Have you tried flying in FBWA?

      If that's sluggish or non responsive then definitely do the autotune. My Cessna was almost un-flyable in FBWA until I did the tune and now it's perfect.

  • Hey Nils, 
    Just saw your post now.  I'm having same problem with my Ublox and APM2.5.2
    Wondering if I need a GPS also.


  • I'd recommend this as an alternative -http://www.drotek.fr/shop/en/home/512-ublox-neo-m8-gps-hmc5983-comp...

    Just changed my m6 for it and I get much quicker gps lock on cold and warm start, usually 20sec cold and 3-5sec warm. I also now get around 17 satellites where as before I'd get 7-8 and upto 11 if I was lucky and Hdop is down to 1.1 from 1.7.

    The apm should be sending 3.3v to the gps, if it isn't theres a possibility your 3.3v regulator has blown on the apm.

  • Hi Nils,

    Not much help on this forum. I'm new to APM & had issue getting GPS to function. I have it working now with lots of Googling & stuff I found here plus RC Groups.

    Your GPS is connecting so must be set to 38,400baud. Mine was set to 9600 which is UBlox default. I got mine working by uploading 3DR_Ublox.txt file. See here for instructions https://github.com/jlnaudin/x-drone/wiki/How-to-setup-the-GPS-Ublox...  & http://copter.ardupilot.com/wiki/common-ublox-gps/

    Once Ublox is programmed it will connect with APM2.6. The first time satellite acquisition  must be in open air & can take up to 30minutes. After that mine will take approx. 3-5minutes to 3D lock. The same Ublox 6m on my Multiwii quad will get 3D fix in less that a minute from cold start & 30 seconds warm start. I've ordered another Ublox to find out if slow lock is due to the UBlox or APM software.

    The Ublox 6m module should have a 3.3V regulator so runs happily on 5V. If you are running APM on 4.6V it is too low. APM 2.6 requires 5.3V & drops .3V by series protection diode.

    • Thank you for the answer Brew!

      I didnt know that. I did return my ublox and got a new one in the mail yesterday. I will post a reply when i have tested it. 3-5 min to lock is a long time when all you want to is to fly! Mine seamed to get lock in 30 secs. Atleast i had the lock symbol in my googles after 30 secs.

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…