Battery voltage and current measurement - unusable?

Hi there,

I'm having a hell of a time figuring out how the battery voltage and current is supposed to work. Sure, the installation is straight forward and I get numbers that change. The problem is that they are not the right numbers:

 - the first problem is that it appears that what the APM 2.6 is getting and what the MissionPlanner is getting are two different numbers: in particular, in the mission planner you can calibrate the sensor, while in the APM you cannot? I mean, it seems that whatever you can calibrate in the Mission Planner is kept in the Mission Planner and used to correct the voltage displayed on the screen rather than the one measured by the APM. Why is that a problem? Because the failsafe is set in the APM, so if the APM is 1V off (yes, that much!), then the failsafe is not doing its job.

- second problem is that it seems that in the latest version of the mission planner (2.**.85) the calibration of the 3DR sensor *voltage* has been disabled. Not sure why, but it is. The current can still be calibrated, but the measured voltage field has been disabled (was enabled in the previous version, and it is still enabled for "Other sensors").


  - is there a way to calibrate a 3DR sensor in the APM? I looked a bit and there seem to be no parameters related to the voltage/current calibration in the APM list of parameters.

 - is there a better sensor out there?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • You know i've been having the same issues with my 3DR power module and pulling my hair out. Values would be OK for the first couple minutes, but after about 60-120 seconds the readings would be way off (by 1v, 1.5v at times). I've tried tests on 2 3DR power modules and the results are the same:


    so for this picture, I first plugged the battery into the power module, then read the correct voltage from the balance plug, lastly entered the proper value so the multiplier changes. Here were the readings after the copter sat on my bench for about a minute. It's crazy!

    The only thing that fixed this for me was getting a longer cable that connects my power module to the APM. I happened to have purchased it as a backup, and for the hell of it tried it. Now my voltage is only about .10 - .30 off. I test this by checking voltages before, in the middle, and after flight. I don't know how this makes sense, but switching to the shorter cable immediately goes back to improper voltage readings.

  • MR60

    I experience the same difficulty to get correct voltage and especially current measurements with an attopilot, although I followed exactly Randy's calibration procedure. In fact the voltage measurement field modified itself! So it drifts for an unknown reason.

    For current measurement it is calibrated at ten amps as advised in the calibration procedure. But then at lower currents the displayed current measurement is totally wrong... Unusable. 

    So I fly only on the basis of the approximative voltage measurement.

    I did another test with my 3DR quad, 3dr PM module and last mission planner: same issues, the current measurements are totally off. Voltage also. I had to select "other sensor" to calibrate correct voltage values! Current remains totally wrong. It seems the last versions of planner introduce these bugs... Hope they will correct that fast want it is kind of critical.

  • Admin


    The reason that the sensor voltage cannot be calibrated is possibly because you have not selected the APM analog pin for the battery voltage measurement. It is usually A13. You can select and store the pin value in the Advanced Parameter List.

    I have found the PM voltage measurement accuracy to be reasonable in relation to the electrical noise environment that the APM and PM are operating in.

    The APM/PM reading of my LiPo battery is within +/-0.2 vdc when compared to my DMM, however the reading of my two NiMH batteries are well outside of the +/- 0.2 vdc when compared to my DMM and I have used the "measured" voltage function to correct the readings. Now the NiMH voltage readings are within +/-0.2 vdc of my DMM reading.

    You are using the radio telemetry to calibrate the battery measurement function as you should not have the battery connected to the PM at the same time the USB is connected to the APM?


    TCIII ArduRover2 Developer

This reply was deleted.