Broken Compass Calibration feature in MP when using APM3.2.1 + Hexacopter

I had an old APM flight controller (3.2.1 fw) that I thought I would put to work on a HEX.  When I tried to calibrate the compass using MP 1.3.44, I got a "Compass Calibration FAILED" message.  No matter how I tried, I couldn't get the compass to calibrate when using the dynamic calibration method.

I connected using USB, then radio.  Neither one would work. The little "globe" rotated, and points lit up.  It appeared to work, but wouldn't complete successfully.

Finally, I brought up APM Planner2.  That worked fine.

So, apparently Mission Planner's compass calibration routine (at least with APM boards and HEX models) is broken. 

If I perform the compass calibration routine, and MP says there is a fail, do the offsets get stored in the flight controller, or not?  In other words, did the compass calibration actually work in the controller even though MP said it did not?

Views: 115

Reply to This

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service