Edited: 7-11-2019
I need help in understanding is there something I am doing wrong “or” there is bug either in “Plane 3.9.8 Official” or Mission Planner version 1.3.68 Build 1.3.7105.26478 Ardu Plane V3.9.8 (6ea22c9c).

  1. I am using PixHawk 2.4.8
  2. Firmware uploaded perfectly, Accel, Compass and radio calibration no issues.
  3. When you get to ESC calibration section and click on the button, I am keep getting this error message; "Set Param error. Please ensure your version is AC3.3+)

You click ok and nothing happens. Unable to go any further pass this stage. ESC Type drop down box can not be selected either as its not available.

Is this ESC calibration feature not applicable when using Frame type to be Ardu Plane?

My ESC is EMAX BLHeli 40A, with +5V UBEC. When I connect the ESC directly to a receiver (Channel 3), put TX throttle stick to full, power on the ESC, it calibirates perfectly fine and I can turn the motor on and off via TX.

When I connect the ESC to PixHawk Channel 3, power on the PixHawk, the PixHawk powers up fine. I can control the Servos, but when I give it a full throttle, motor doesn’t start.

Inside Mission planner, I can see the PWM value of channel 3 is ranging from 982 to 2006. Any idea why the motor is not starting via PixHawk? Why Mission planner “or” PixHawk is failing here?

Note: Inside Mission planner, section “Servo output”, if I click on reverse Throttle, the motor does start at full speed but again the TX throttle stick has no effect on it. For sure it looks like PWM issue.

Furthermore, Inside “Servo Output” Section inside Mission planner, when I move the throttle stick, the values DO NOT Change, however under radio calibration value do change for throttle stick. This is very strange…so lost…

=====================================================================

SOLUTION:

WIRING - You wire PixHawk as you would normally wire for a Plane config (CHAN 1 - Aileron, CHAN 2 - Elevator, CHAN 3 - Throttle to ESC, CHAN 4- Rudder) - except put a switch or have the ability to disable power to Throttle/Motor ESC power that would normally come from PixHawk Power regulator to ESC.

Initially Keep this power switch off so no power to ESC.

Note: I am assuming at this point you have gone through basic steps of Accel, compass, and radio calibration and also have set your flight mode switch. We must be able to select stabilize mode to do this process.

MISSION PLANNER RELATED CHANGES.

  1. Power up PixHawk via your battery.
  2. Connect with Mission Planner.
  3. Go to “Config/Tuning” section. and select “Standard Parameters” from left side.
  4. Scroll Down till you see “Arm Checks to perform”. By default “All” is selected. Just un-check "All just for ESC calibiration process. make sure to come back here again and enable whatever Pre checks you want to enable.
  5. Click “write param” button to save settings.
  6. Turn off the battery and power down the PixHawk.

ESC Calibration Process.

  1. Remove your propellers for safety
  2. Power up just the flight board (No Power to ESC).
  3. By default the Q_ESC_CAL parameter is set to 1 (I still Dont know where to find this parameter)
  4. Put PixHawk in STABILIZE mode. Must do that.
  5. Arm the safety switch ont he PixHawk to activate the PixHawk outputs.
  6. Now, arm your aircraft by pushing the Throttle stick down to the right. The PWM output on Channel 3 will now be controlled by your throttle stick.
  7. Move the throttle stick to maximum.
  8. Now, add power to your ESC by connecting the battery/cable or enabling the switch.
  9. Wait for the ESC to beep to indicate they have registered the maximum PWM.
  10. lower the throttle stick to zero and disarm your aircraft.
  11. You may hear a beep from your ESC to indicate they have registered the throttle range.

At this point if you move back the Throttle stick up, the motor should start to run. if not, simply power down the PixHawk, power it up but also provide power to ESC as well.

The throttle should make the motor to spin!!!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks for sharing the information it was very helpful for me https://run3sonline.com
    Run 3 - Play Free Online Games Now!
    Run 3 is the best selection of run series. Enjoy game with your friends and playing Run 3
  • Hey there, I was having this problem and I appreciate you taking the time to write out this guide. However, even trying this I could not get the motor to spin. The ESC does not seem to be the problem as I connected it to a regular transceiver and the motor spun up just fine, I was able to manually calibrate it. I am using a Pixhawk 4 loaded with Arduplane 4.07 and have the ESC wired to M1. I have calibrated my transmitter, but still no results. Any ideas? Thanks!
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ : A Home-brew computer club* for Connected Autonomous Driving. talk at #piandmore ⁦@PiAndMore⁩ on Jan 23rd h…
yesterday
DIY Robocars via Twitter
RT @a1k0n: New blog post! Deep dive into my ceiling light based localization algorithm which runs in 1ms on a Raspberry Pi 3: https://t.co/…
yesterday
DIY Robocars via Twitter
Great new guide to using @donkey_car https://custom-build-robots.com/donkey-car-e-book-en
yesterday
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars virtual AI race is tomorrow morn at 9:00am PT. You can watch live on Twitch https://www.meetup.com/DIYRobocars/events/275268196/
Friday
DIY Robocars via Twitter
New version of Intel OpenBot! This resolves many of the issues with the first version, including a much smoother tr… https://twitter.com/i/web/status/1352395636369313798
Thursday
DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
Tuesday
DIY Drones via Twitter
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
Jan 15
DIY Robocars via Twitter
Jan 15
DIY Drones via Twitter
Jan 14
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Jan 14
DIY Robocars via Twitter
Jan 14
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
More…