Calibrating compass offsets, crashing IMU?

I'm trying to calibrate my compass offsets using xbees for the communication. Everytime I get the menu in the CLI it cuts off around line r

 

r - Reset to fa

 

And when I use c to do compass offsets it streams the numbers for about 15-30 seconds and then stops and the IMU instead of walking red orange green it stays solid green?

 

Does this mean the IMU has crashed? I can only restart it to get it back and also have to debrick the xbee also because it seems to get corrupted in the process.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • You're not getting a solid red on the IMU or no red at all?
    It should blink if GPS hold is on and there's no GPS data. Even if there's no GPS hooked up.

    If you're not even getting it to blink, then you're not getting the GPS hold mode on. Which means you should probably check your RC.
    Did you change the software since the last time you had GPS working? Are you sure you have it enabled in Config.h?

    Re: magnetometer - 1-2 degrees should be fine, methinks.
  • Developer

     

       The noise issues were resolved within days of that post from Jordi going up saying they'd found a problem.  That was months ago and I haven't heard any compliant so I think it's all a-ok.  I've personally ordered two mags since that time and they're working beautifully.

  • I received at the end of March a HMC5843 - Triple Axis Magnetometer Rev 1.2

     

    Do you know if this has the noise issue resolved? The last one i had to remove the little resistor but this time I soldered it to the IMU and forgot to check first. :-/

     

    Is 1.2 ok? It's the latest version?

  • I always set the xbees to 115k. Is that the right rate?

     

    When the IMU is in CLI mode (walking leds) and it stops and displays solid green, does that indicate it's crashed?

     

    Also when I pull the battery and restart, (before connecting the blue xbee wire, to avoid bricking it) the blue and red lights flicker until I plug in the blue wire and then the red and blue stay on and I have to debrick it.

     

    The reason I was wanting to do the magneto configuration wirelessly is so I can spin it around without risking pulling out the usb cable. Most people are doing it via usb?

  • Developer

    I think you likely need to increase the baud rate of the xbee.  The CLI menu is displayed all at once so it's a reasonably large amount of text that needs to get through the Xbee in a short period of time.  I think what's happening here is that the outboard buffer on the APM is filling up.  Sorry, I'm not sure if the APM crashes when the buffer overflows (I hope not)

     

    Personally I've never used the XBee to do configuration although i believe many others have.

This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Thursday
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Thursday
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Thursday
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Thursday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…