"Camera Target" Icon in Mission Planner

After upgrading to the latest Mission Planner version, I now have a "Camera Target" pushpin on the map in the Flight Data screen.

I cannot find any way to disable this. What is it's purpose? I am not yet using a gimbal or controlling a camera shutter with the APM.

I am using one of the camera gimbal outputs on the analog output pins to control some LED lights on my copter, but disabling all of the gimbal channels still doesn't remove the camera target.

I have tried right clicking it, clicking and dragging, etc. and can't interact with it in the flight data screen and searching the full parameter list for "camera" and "target" doesn't come up with anything that seems to apply.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Elevation tool working. I guess I didn't notice "home" elevation had changed.
    In latest beta I'm getting a geofence breach warning. I checked all para. and they appear to be in a "disable" state.
    Anyone ideas on how to fix?
  • any news on this.. it's really annoying but i can't seem to get rid of it..

  • I've also noticed that in Flight Planner, the map tool, "elevation graph" is not working correctly.

  • I've been meaning to ask the same question.
This reply was deleted.