Can't connect Mission planner to APM 2.0


Yesterday I decided to install my APM 2.0 board that I bought few years ago (never used) to my FPV plane. I downloaded mission planner, uploaded arduplane 2.78b firmware to APM board from MP, connection with USB cable worked without problems.

Than I connected 3DR radios that worked good with my old APM1 board, but I was not able to connect :(

When I'm trying to read radio parameters from mission planner, it reads ground and remote side without problems, communication between modules is ok (solid green led). All setting are identical and UART data goes from one radio to another without problems.

Then I reflashed both radios from MP - firmware version changed from 1.5 to 1.9. Still no changes. I sniffed communication with USB-UART adapter - while trying to connect mission planner periodically sends some request bytes to APM board and APM board didn't send nothing back to MP. There is no data at TX port of APM board at all - on startup, while trying to connect, never... I checked APM telemetry port speed setting - it is same as radio setting (57600).

Can you give me some advise about solving my problem, please?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Can u tell me how u switched the output signals? I have a dead output channel #7 for my on a tricopter. Hoping to make 8 or 6 work instead for the servo..
  • Developer
    If it worked before, you will not need to re-wire anything. I had a similar problem when upgrading to V1.8. The fix was to trigger a factory reset for each radio.
    • How can I trigger factory reset?

      • And it was working on another APM board (version 1)

  • Try to swap Rx and Tx line on APM side.

    • Tryed, no effect :(

      • Hey have you checked your voltages by chance? I hear that trying to power too many devices via USB can damage the unit. If you've got a meter give it a test.. if you unplug it can you still connect via USB and see all of your compass, accel, etc...?

        • If he will power APM via USB, there will be no telemetry.

          Alexander, if you want to connect via telemetry link - you have to power APM by BEC or Power Module. USB must be unplugged.

          • I can see all sensors readings and everything seems to work good when I connect board to PC by USB cable.

            When I'm testing 3DR radios, I'm powering APM board with PTH08080WAH switching regulator tuned to 5V (2.2A max output current).

            First time I powered APM board to RC reciever pins, but there were no 5V output to servos. Than I read manual carefully and switched power to servo output pins. All working fine, but no 3DR radios :(

            Voltage on 3DR radio power pins is 4.7V.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25